aboutsummaryrefslogtreecommitdiffstats
path: root/math/R-cran-prodlim/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/R-cran-prodlim/Makefile')
-rw-r--r--math/R-cran-prodlim/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/math/R-cran-prodlim/Makefile b/math/R-cran-prodlim/Makefile
new file mode 100644
index 000000000000..ce08df4af22f
--- /dev/null
+++ b/math/R-cran-prodlim/Makefile
@@ -0,0 +1,21 @@
+# Created by: TAKATSU Tomonari <tota@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= prodlim
+PORTVERSION= 1.6.1
+CATEGORIES= math
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= Product-Limit Estimation for Censored Event History Analysis
+
+LICENSE= GPLv2+
+
+CRAN_DEPENDS= R-cran-Rcpp>=0.11.5:devel/R-cran-Rcpp \
+ R-cran-lava>0:math/R-cran-lava
+BUILD_DEPENDS= ${CRAN_DEPENDS}
+RUN_DEPENDS= ${CRAN_DEPENDS}
+
+USES= cran:auto-plist,compiles
+
+.include <bsd.port.mk>