aboutsummaryrefslogtreecommitdiffstats
path: root/math/digitizer/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/digitizer/Makefile')
-rw-r--r--math/digitizer/Makefile71
1 files changed, 71 insertions, 0 deletions
diff --git a/math/digitizer/Makefile b/math/digitizer/Makefile
new file mode 100644
index 000000000000..56b31449faa8
--- /dev/null
+++ b/math/digitizer/Makefile
@@ -0,0 +1,71 @@
+# New ports collection makefile for: digitizer
+# Date created: 27 May 2006
+# Whom: Thierry Thomas <thierry@pompo.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= digitizer
+PORTVERSION= 2.14
+CATEGORIES= math graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= digit-src-${PORTVERSION:S/./_/}
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= Engauge Digitizer - Digitizing software to convert graphs into numbers
+
+BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USE_QT_VER= 3
+QTDIR?= ${X11BASE}
+MAKE_ENV= QMAKESPEC="${LOCALBASE}/share/qt/mkspecs/freebsd-g++" \
+ QTDIR="${QTDIR}"
+
+DESKTOP_ENTRIES= "Engauge Digitizer" \
+ "Digitizing software to convert graphs into numbers" \
+ "${DATADIR}/lo16-app-digitizer.png" \
+ "${PORTNAME}" \
+ "Education;Math;" \
+ true
+
+.if !defined(NOPORTDOCS)
+DOCS= README REGRESSION_TESTS
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500035
+BROKEN= Does not compile with gcc-2.95
+.endif
+
+pre-configure:
+.if !defined(WITH_DEBUG)
+ ${REINPLACE_CMD} -e '/^CONFIG/s/debug/release/' ${WRKSRC}/digitizer.pro
+.endif
+ ${REINPLACE_CMD} -e 's|Path1("usermanual")|Path1("${DOCSDIR}/usermanual")|' \
+ ${WRKSRC}/src/digitmain.cpp
+
+pre-build:
+ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} qmake -unix digitizer.pro
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/src/img/lo16-app-digitizer.png \
+ ${DATADIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}/usermanual
+ ${INSTALL_DATA} ${DOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ cd ${WRKSRC}/usermanual && ${FIND} . -type f -depth 1 \
+ -exec ${INSTALL_DATA} {} ${DOCSDIR}/usermanual \;
+ @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+ ${MKDIR} ${EXAMPLESDIR}
+ cd ${WRKSRC}/samples && ${FIND} . -type f -depth 1 \
+ -exec ${INSTALL_DATA} {} ${EXAMPLESDIR} \;
+ @${ECHO_MSG} "===> Examples installed in ${EXAMPLESDIR}."
+.endif
+
+.include <bsd.port.post.mk>