aboutsummaryrefslogtreecommitdiffstats
path: root/math/gretl/files/patch-configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'math/gretl/files/patch-configure.in')
-rw-r--r--math/gretl/files/patch-configure.in47
1 files changed, 44 insertions, 3 deletions
diff --git a/math/gretl/files/patch-configure.in b/math/gretl/files/patch-configure.in
index 878856ca23be..68d83eb1fac6 100644
--- a/math/gretl/files/patch-configure.in
+++ b/math/gretl/files/patch-configure.in
@@ -1,6 +1,34 @@
---- configure.in.orig Wed Apr 9 01:11:09 2003
-+++ configure.in Mon Apr 14 15:16:28 2003
-@@ -417,7 +417,7 @@
+--- configure.in.orig Fri May 2 00:17:37 2003
++++ configure.in Fri May 23 12:31:12 2003
+@@ -169,6 +169,16 @@
+ fi,
+ try_gmp=yes)
+
++AC_ARG_WITH(lapack,
++[ --with-lapack Use LAPACK library [default=auto]],
++if test "x${withval}" = "xno"
++then
++ try_lapack=no
++else
++ try_lapack=yes
++fi,
++try_lapack=yes)
++
+ AC_ARG_WITH(x-12-arima,
+ [ --with-x-12-arima include X-12-ARIMA support [default=yes]],
+ if test "${withval}" = "no"
+@@ -277,7 +287,9 @@
+ *darwin*) LAPACK_LIBS="-Wl,-framework -Wl,vecLib"
+ ;;
+ esac
+-AM_PATH_LAPACK(, have_lapack="yes")
++if test x"${try_lapack}" != xno ; then
++ AM_PATH_LAPACK(, have_lapack="yes")
++fi
+
+ dnl
+ dnl Check for gnuplot, and its PNG capacity
+@@ -392,7 +404,7 @@
dnl Check for libpng
dnl
if test ${png_comments} = yes && test ${have_gtk} = "2.0" ; then
@@ -9,3 +37,16 @@
png_failed="no",
png_failed="yes"
)
+@@ -557,12 +569,6 @@
+ echo "
+ Please install libxml and then reconfigure gretl.
+ libxml is available from http://xmlsoft.org/
+-"
+-
+-elif test "${have_lapack}" = "no" ; then
+-echo "
+-Please install lapack and then reconfigure gretl.
+-Lapack is available from http://www.netlib.org/lapack/
+ "
+
+ else