aboutsummaryrefslogtreecommitdiffstats
path: root/math/octave
diff options
context:
space:
mode:
Diffstat (limited to 'math/octave')
-rw-r--r--math/octave/Makefile14
-rw-r--r--math/octave/pkg-plist2
2 files changed, 4 insertions, 12 deletions
diff --git a/math/octave/Makefile b/math/octave/Makefile
index fe0d93d1734b..2828452fba51 100644
--- a/math/octave/Makefile
+++ b/math/octave/Makefile
@@ -112,20 +112,14 @@ post-install:
@${FIND} -s ${STAGEDIR}$d -not -type d -not -name '*.la' | \
${SED} -e 's#^${STAGEDIR}${PREFIX}/##' >> ${WRKDIR}/PLIST
@${FIND} -s ${STAGEDIR}$d -type d -empty | \
- ${SED} -e 's,^${STAGEDIR}${PREFIX}/,@exec ${MKDIR} %D/,' \
- -e 's,$$, 2>/dev/null || true,' >> ${WRKDIR}/PLIST
- @${FIND} -s ${STAGEDIR}$d -type d -depth | \
- ${SED} -e 's,^${STAGEDIR}${PREFIX}/,@dirrm ,' >> ${WRKDIR}/PLIST
+ ${SED} -e 's,^${STAGEDIR}${PREFIX}/,@dir ,' \
+ >> ${WRKDIR}/PLIST
.endfor
.for d in ${PREFIX}/libexec/octave/api-v49+ ${PREFIX}/libexec/octave/site ${PREFIX}/lib/octave/site
@${FIND} -s ${STAGEDIR}$d -type d -empty | \
- ${SED} -e 's,^${STAGEDIR}${PREFIX}/,@exec ${MKDIR} %D/,' \
- -e 's,$$, 2>/dev/null || true,' >> ${WRKDIR}/PLIST
- @${FIND} -s ${STAGEDIR}$d -type d -depth | \
- ${SED} -e 's,^${STAGEDIR}${PREFIX}/,@dirrm ,' >> ${WRKDIR}/PLIST
+ ${SED} -e 's,^${STAGEDIR}${PREFIX}/,@dir ,' \
+ >> ${WRKDIR}/PLIST
.endfor
- ${ECHO_CMD} @dirrm libexec/octave >> ${WRKDIR}/PLIST
- ${ECHO_CMD} @dirrm share/octave >> ${WRKDIR}/PLIST
cd ${WRKDIR} ; ${SED} -i.bak -e "/PLIST/ r PLIST" ${TMPPLIST}
check regression-test: build
diff --git a/math/octave/pkg-plist b/math/octave/pkg-plist
index 43f6d4fd96e1..e03917ab16b1 100644
--- a/math/octave/pkg-plist
+++ b/math/octave/pkg-plist
@@ -16,6 +16,4 @@ share/applications/www.octave.org-octave.desktop
%%PORTDOCS%%%%DOCSDIR%%/refcard-legal.ps
%%PORTDOCS%%%%DOCSDIR%%/refcard-letter.ps
%%PORTDOCS%%%%DOCSDIR%%/octave.ps
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
@comment Insert PLIST here
-@dirrm lib/octave