aboutsummaryrefslogtreecommitdiffstats
path: root/math/plplot/files
diff options
context:
space:
mode:
Diffstat (limited to 'math/plplot/files')
-rw-r--r--math/plplot/files/patch-Makefile.in11
-rw-r--r--math/plplot/files/patch-bindings::tcl::Makefile.in11
-rw-r--r--math/plplot/files/patch-bindings::tk::Makefile.in11
-rw-r--r--math/plplot/files/patch-cmake_modules_FindTCL.cmake12
-rw-r--r--math/plplot/files/patch-cmake_modules_FindVGA.cmake15
-rw-r--r--math/plplot/files/patch-cmake_modules_instdirs.cmake45
-rw-r--r--math/plplot/files/patch-cmake_modules_linuxvga.cmake17
-rw-r--r--math/plplot/files/patch-cmake_modules_pkg-config.cmake11
-rw-r--r--math/plplot/files/patch-cmake_modules_tcl-related.cmake32
-rw-r--r--math/plplot/files/patch-drivers::Makefile.in11
-rw-r--r--math/plplot/files/patch-lib::csa::Makefile.in11
11 files changed, 132 insertions, 55 deletions
diff --git a/math/plplot/files/patch-Makefile.in b/math/plplot/files/patch-Makefile.in
deleted file mode 100644
index db887516f9b1..000000000000
--- a/math/plplot/files/patch-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig Mon Feb 2 20:40:55 2004
-+++ Makefile.in Tue Feb 10 00:55:31 2004
-@@ -835,7 +835,7 @@
-
- info-am:
-
--install-data-am: install-docDATA
-+install-data-am:
-
- install-exec-am: install-binSCRIPTS
-
diff --git a/math/plplot/files/patch-bindings::tcl::Makefile.in b/math/plplot/files/patch-bindings::tcl::Makefile.in
deleted file mode 100644
index 9f1904a7d45b..000000000000
--- a/math/plplot/files/patch-bindings::tcl::Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- bindings/tcl/Makefile.in.orig Thu Apr 21 05:35:22 2005
-+++ bindings/tcl/Makefile.in Sun May 8 12:18:36 2005
-@@ -482,7 +482,7 @@
- with_qhull_TRUE = @with_qhull_TRUE@
- with_rpath_FALSE = @with_rpath_FALSE@
- with_rpath_TRUE = @with_rpath_TRUE@
--tcldir = $(TCL_DIR)
-+@enable_tcl_TRUE@tcldir = $(TCL_DIR)
- libplplot = $(top_builddir)/src/libplplot$(LIB_TAG).la
- libmatrix = libtclmatrix$(LIB_TAG).la
- @enable_tcl_TRUE@generated_scripts = plplot.tcl
diff --git a/math/plplot/files/patch-bindings::tk::Makefile.in b/math/plplot/files/patch-bindings::tk::Makefile.in
deleted file mode 100644
index cf97ac73ed55..000000000000
--- a/math/plplot/files/patch-bindings::tk::Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- bindings/tk/Makefile.in.orig Thu Apr 21 05:35:23 2005
-+++ bindings/tk/Makefile.in Sun May 8 12:19:29 2005
-@@ -467,7 +467,7 @@
- with_qhull_TRUE = @with_qhull_TRUE@
- with_rpath_FALSE = @with_rpath_FALSE@
- with_rpath_TRUE = @with_rpath_TRUE@
--tcldir = $(TCL_DIR)
-+@enable_tk_TRUE@tcldir = $(TCL_DIR)
- libplplottcltk = $(top_builddir)/bindings/tcl/libplplottcltk$(LIB_TAG).la
- libplplot = $(top_builddir)/src/libplplot$(LIB_TAG).la
-
diff --git a/math/plplot/files/patch-cmake_modules_FindTCL.cmake b/math/plplot/files/patch-cmake_modules_FindTCL.cmake
new file mode 100644
index 000000000000..77ee1e4edc2d
--- /dev/null
+++ b/math/plplot/files/patch-cmake_modules_FindTCL.cmake
@@ -0,0 +1,12 @@
+--- cmake/modules/FindTCL.cmake.orig 2009-09-06 21:04:43.000000000 +0200
++++ cmake/modules/FindTCL.cmake 2009-12-25 16:15:45.000000000 +0100
+@@ -121,7 +121,9 @@
+ /usr/include
+ /usr/local/include
+ /usr/include/tcl8.5
++ /usr/include/tk8.5
+ /usr/include/tcl8.4
++ /usr/include/tk8.4
+ /usr/include/tcl8.3
+ /usr/include/tcl8.2
+ /usr/include/tcl8.0
diff --git a/math/plplot/files/patch-cmake_modules_FindVGA.cmake b/math/plplot/files/patch-cmake_modules_FindVGA.cmake
new file mode 100644
index 000000000000..6299240cc2a5
--- /dev/null
+++ b/math/plplot/files/patch-cmake_modules_FindVGA.cmake
@@ -0,0 +1,15 @@
+--- cmake/modules/FindVGA.cmake.orig 2009-09-06 21:04:43.000000000 +0200
++++ cmake/modules/FindVGA.cmake 2009-12-25 20:27:51.000000000 +0100
+@@ -6,7 +6,6 @@
+ # VGA_LIBRARIES, the libraries to link against to use the vga library
+ # VGA_LIBRARY_DIRS, the directory where the vga library is found.
+
+-if(CMAKE_SYSTEM_NAME STREQUAL "Linux")
+ find_path(VGA_INCLUDE_DIR vga.h /usr/local/include /usr/include)
+
+ if(VGA_INCLUDE_DIR)
+@@ -33,4 +32,3 @@
+ message(FATAL_ERROR "FindVGA: Could not find vga.h and/or the vga library")
+ endif(VGA_FIND_REQUIRED)
+ endif(VGA_FOUND)
+-endif(CMAKE_SYSTEM_NAME STREQUAL "Linux")
diff --git a/math/plplot/files/patch-cmake_modules_instdirs.cmake b/math/plplot/files/patch-cmake_modules_instdirs.cmake
new file mode 100644
index 000000000000..a9b98637ae64
--- /dev/null
+++ b/math/plplot/files/patch-cmake_modules_instdirs.cmake
@@ -0,0 +1,45 @@
+--- ./cmake/modules/instdirs.cmake.orig 2009-09-06 21:04:43.000000000 +0200
++++ ./cmake/modules/instdirs.cmake 2009-12-26 22:13:15.000000000 +0100
+@@ -61,13 +61,13 @@
+
+ set(
+ CMAKE_INSTALL_INFODIR
+-${CMAKE_INSTALL_DATADIR}/info
++${CMAKE_INSTALL_PREFIX}/info
+ CACHE PATH "install location for info documentation"
+ )
+
+ set(
+ CMAKE_INSTALL_MANDIR
+-${CMAKE_INSTALL_DATADIR}/man
++${CMAKE_INSTALL_PREFIX}/man
+ CACHE PATH "install location for man documentation"
+ )
+
+@@ -75,7 +75,7 @@
+ # cached values above.
+
+ # Data.
+-set(DATA_DIR ${CMAKE_INSTALL_DATADIR}/${PACKAGE}${VERSION})
++set(DATA_DIR ${CMAKE_INSTALL_DATADIR}/${PACKAGE})
+
+ # Libraries.
+ set(LIB_DIR ${CMAKE_INSTALL_LIBDIR})
+@@ -90,7 +90,7 @@
+ set(SHLIB_DIR ${CMAKE_INSTALL_LIBDIR})
+
+ # Tcl files.
+-set(TCL_DIR ${CMAKE_INSTALL_DATADIR}/${PACKAGE}${VERSION}/tcl)
++set(TCL_DIR ${CMAKE_INSTALL_DATADIR}/${PACKAGE}/tcl)
+
+ # Ada source files (*.adb, *.ads) (following recommendations in
+ # http://www.ada-france.org/debian/debian-ada-policy.html
+@@ -101,7 +101,7 @@
+ set(ADA_LIB_DIR ${CMAKE_INSTALL_LIBDIR}/ada/adalib/plplotada${LIB_TAG})
+
+ # Drivers.
+-set(DRV_DIR ${CMAKE_INSTALL_LIBDIR}/${PACKAGE}${VERSION}/drivers${LIB_TAG})
++set(DRV_DIR ${CMAKE_INSTALL_LIBDIR}/${PACKAGE}/drivers${LIB_TAG})
+
+ # Documentation.
+ set(DOC_DIR ${CMAKE_INSTALL_DATADIR}/doc/${PACKAGE})
diff --git a/math/plplot/files/patch-cmake_modules_linuxvga.cmake b/math/plplot/files/patch-cmake_modules_linuxvga.cmake
new file mode 100644
index 000000000000..7b4144171a59
--- /dev/null
+++ b/math/plplot/files/patch-cmake_modules_linuxvga.cmake
@@ -0,0 +1,17 @@
+--- ./cmake/modules/linuxvga.cmake.orig 2009-09-06 21:04:43.000000000 +0200
++++ ./cmake/modules/linuxvga.cmake 2009-12-26 23:58:37.000000000 +0100
+@@ -35,7 +35,6 @@
+ # set the environment variable CMAKE_LIBRARY_PATH.
+ # See cmake documentation for further details.
+
+-if(CMAKE_SYSTEM_NAME STREQUAL "Linux")
+ if(PLD_linuxvga)
+ find_package(VGA)
+ if(VGA_FOUND)
+@@ -50,6 +49,3 @@
+ set(PLD_linuxvga OFF CACHE BOOL "Enable linuxvga device" FORCE)
+ endif(VGA_FOUND)
+ endif(PLD_linuxvga)
+-else(CMAKE_SYSTEM_NAME STREQUAL "Linux")
+- set(PLD_linuxvga OFF CACHE BOOL "Enable linuxvga device" FORCE)
+-endif(CMAKE_SYSTEM_NAME STREQUAL "Linux")
diff --git a/math/plplot/files/patch-cmake_modules_pkg-config.cmake b/math/plplot/files/patch-cmake_modules_pkg-config.cmake
new file mode 100644
index 000000000000..77b9fd5f4b68
--- /dev/null
+++ b/math/plplot/files/patch-cmake_modules_pkg-config.cmake
@@ -0,0 +1,11 @@
+--- ./cmake/modules/pkg-config.cmake.orig 2009-09-06 21:04:43.000000000 +0200
++++ ./cmake/modules/pkg-config.cmake 2009-12-26 23:55:00.000000000 +0100
+@@ -48,7 +48,7 @@
+ if(PKG_CONFIG_EXECUTABLE)
+ message(STATUS "Looking for pkg-config - found")
+ set(pkg_config_true "")
+- set(PKG_CONFIG_DIR ${LIB_DIR}/pkgconfig)
++ set(PKG_CONFIG_DIR ${LIB_DIR}data/pkgconfig)
+ set(PKG_CONFIG_ENV PKG_CONFIG_PATH=${PKG_CONFIG_DIR})
+ else(PKG_CONFIG_EXECUTABLE)
+ message(STATUS "Looking for pkg-config - not found")
diff --git a/math/plplot/files/patch-cmake_modules_tcl-related.cmake b/math/plplot/files/patch-cmake_modules_tcl-related.cmake
new file mode 100644
index 000000000000..52a0b4d3c390
--- /dev/null
+++ b/math/plplot/files/patch-cmake_modules_tcl-related.cmake
@@ -0,0 +1,32 @@
+--- cmake/modules/tcl-related.cmake.orig 2009-09-06 21:04:43.000000000 +0200
++++ cmake/modules/tcl-related.cmake 2009-12-25 17:44:43.000000000 +0100
+@@ -98,11 +98,13 @@
+ WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}/cmake/modules
+ OUTPUT_VARIABLE itcl_library_versions)
+ message(STATUS "Looking for itcl.h")
+- find_path(ITCL_INCLUDE_PATH itcl.h ${TCL_INCLUDE_PATH})
++ find_path(ITCL_INCLUDE_PATH itcl.h ${TCL_INCLUDE_PATH}/../itcl%%ITCL_VER%%)
+ if(ITCL_INCLUDE_PATH)
+ message(STATUS "Looking for itcl.h - found")
+ message(STATUS "Looking for itcl library")
+ get_filename_component(TCL_LIBRARY_PATH ${TCL_LIBRARY} PATH)
++ find_library(ITCL_LIBRARY itcl PATHS ${TCL_LIBRARY_PATH}
++ PATH_SUFFIXES itcl)
+ set(itcl_library_versions 3.4 3.3 3.2 3.1 3.0 2.1 2.0)
+ foreach(version ${itcl_library_versions})
+ find_library(ITCL_LIBRARY itcl${version} PATHS ${TCL_LIBRARY_PATH}
+@@ -158,11 +160,12 @@
+ endif(ENABLE_tk)
+ if(ENABLE_itk)
+ message(STATUS "Looking for itk.h")
+- find_path(ITK_INCLUDE_PATH itk.h ${TK_INCLUDE_PATH})
++ find_path(ITK_INCLUDE_PATH itk.h ${TCL_INCLUDE_PATH}/../itk%%ITCL_VER%%)
+ if(ITK_INCLUDE_PATH)
+ message(STATUS "Looking for itk.h - found")
+ message(STATUS "Looking for itk library")
+- set(itk_library_versions 3.4 3.3 3.2 3.1 3.0 2.1 2.0)
++ find_library(ITK_LIBRARY itk PATH_SUFFIXES itk)
++ set(itk_library_versions "" 3.4 3.3 3.2 3.1 3.0 2.1 2.0)
+ foreach(version ${itk_library_versions})
+ find_library(ITK_LIBRARY itk${version}
+ PATH_SUFFIXES itk${version})
diff --git a/math/plplot/files/patch-drivers::Makefile.in b/math/plplot/files/patch-drivers::Makefile.in
deleted file mode 100644
index 841d12d59ace..000000000000
--- a/math/plplot/files/patch-drivers::Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- drivers/Makefile.in.orig Mon Feb 2 20:41:02 2004
-+++ drivers/Makefile.in Tue Feb 10 01:44:02 2004
-@@ -2069,7 +2069,7 @@
-
- info-am:
-
--install-data-am: install-docDATA install-driversDATA \
-+install-data-am: install-driversDATA \
- install-driversLTLIBRARIES
- @$(NORMAL_INSTALL)
- $(MAKE) $(AM_MAKEFLAGS) install-data-hook
diff --git a/math/plplot/files/patch-lib::csa::Makefile.in b/math/plplot/files/patch-lib::csa::Makefile.in
deleted file mode 100644
index e1e528e7a93a..000000000000
--- a/math/plplot/files/patch-lib::csa::Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/csa/Makefile.in.orig Mon Feb 2 20:41:08 2004
-+++ lib/csa/Makefile.in Tue Feb 10 01:53:21 2004
-@@ -635,8 +635,6 @@
- info-am:
-
- install-data-am:
-- @$(NORMAL_INSTALL)
-- $(MAKE) $(AM_MAKEFLAGS) install-data-hook
-
- install-exec-am: install-libLTLIBRARIES
-