aboutsummaryrefslogtreecommitdiffstats
path: root/math/rpy2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/rpy2/Makefile')
-rw-r--r--math/rpy2/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/math/rpy2/Makefile b/math/rpy2/Makefile
index 9b2e38584cdb..1b84100091ad 100644
--- a/math/rpy2/Makefile
+++ b/math/rpy2/Makefile
@@ -8,7 +8,7 @@
PORTNAME= rpy2
PORTVERSION= 2.1.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math
MASTER_SITES= CHEESESHOP \
SF
@@ -18,7 +18,8 @@ COMMENT= Python interface to the R Programming Language
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy:${PORTSDIR}/math/py-numpy \
R:${PORTSDIR}/math/R
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/numpy:${PORTSDIR}/math/py-numpy \
+ R:${PORTSDIR}/math/R
USE_PYTHON= yes
USE_PYDISTUTILS= yes
@@ -26,4 +27,9 @@ USE_PYDISTUTILS= yes
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/setup.py
+pre-configure:
+ @(if [ ! -e ${LOCALBASE}/lib/R/lib/libR.so ] ; then \
+ ${ECHO_MSG} "==> ${PKGNAME} requires math/R to be built WITH_LIBR" ; \
+ exit 1; fi)
+
.include <bsd.port.mk>