aboutsummaryrefslogtreecommitdiffstats
path: root/math/scigraphica/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/scigraphica/Makefile')
-rw-r--r--math/scigraphica/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/math/scigraphica/Makefile b/math/scigraphica/Makefile
index 4f97f2da6949..9d8c69aad7cf 100644
--- a/math/scigraphica/Makefile
+++ b/math/scigraphica/Makefile
@@ -7,7 +7,7 @@
PORTNAME= scigraphica
PORTVERSION= 0.8.0
-PORTREVISION= 3
+PORTREVISION= 5
CATEGORIES= math gnome
MASTER_SITES= http://scigraphica.sourceforge.net/src/ \
${MASTER_SITE_SOURCEFORGE} \
@@ -37,12 +37,9 @@ MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}"
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
post-install:
- @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${PREFIX}/share/gnome/scigraphica
- @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${PREFIX}/share/gnome/scigraphica
+ @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${PREFIX}/share/scigraphica
+ @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${PREFIX}/share/scigraphica
.include <bsd.port.post.mk>