aboutsummaryrefslogtreecommitdiffstats
path: root/math/superlu_mt
diff options
context:
space:
mode:
Diffstat (limited to 'math/superlu_mt')
-rw-r--r--math/superlu_mt/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/math/superlu_mt/Makefile b/math/superlu_mt/Makefile
index 8dc292b2256c..6ac91cd15e4e 100644
--- a/math/superlu_mt/Makefile
+++ b/math/superlu_mt/Makefile
@@ -97,7 +97,7 @@ do-build:
${FIND} ${WRKSRC_SHARED} -name "*\.a" -exec ${CP} {} ${WRKDIR}/tmp_shared \;
@cd ${WRKDIR}/tmp_shared ; for i in `ls *.a | ${SED} 's/\.a//' `; do \
${RM} -f $${i}.so.* $${i}.so ; \
- ${FC} ${CFLAGS} ${FPIC} ${LDFLAGS} -shared -o $${i}.so.${SVERSION} \
+ ${FC} ${CFLAGS} ${FPIC} ${LDFLAGS} -shared -o $${i}.so.${SVERSION} \
-Wl,-soname,$${i}.so.${SVERSION} -Wl,--allow-multiple-definition \
-Wl,--whole-archive $${i}.a -Wl,--no-whole-archive -Wl,--as-needed; \
${LN} -s $${i}.so.${SVERSION} $${i}.so ;\