aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
Diffstat (limited to 'math')
-rw-r--r--math/glm/Makefile10
-rw-r--r--math/glm/distinfo4
-rw-r--r--math/glm/pkg-plist8
3 files changed, 12 insertions, 10 deletions
diff --git a/math/glm/Makefile b/math/glm/Makefile
index 33c742c5aaf8..ce6806e9118c 100644
--- a/math/glm/Makefile
+++ b/math/glm/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= glm
-PORTVERSION= 0.9.6.3
+PORTVERSION= 0.9.7.1
PORTEPOCH= 1
CATEGORIES= math graphics
-MASTER_SITES= SF/ogl-math/${PORTNAME}-${PORTVERSION}
MAINTAINER= demon@FreeBSD.org
COMMENT= C++ mathematics library for software based on the OpenGL GLSL
@@ -13,10 +12,13 @@ COMMENT= C++ mathematics library for software based on the OpenGL GLSL
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/copying.txt
-USES= zip dos2unix
+USE_GITHUB= yes
+GH_ACCOUNT= g-truc
+
+USES= dos2unix
+DOS2UNIX_FILES= glm/detail/dummy.cpp
NO_ARCH= yes
NO_BUILD= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}
do-install:
cd ${WRKSRC} && ${COPYTREE_SHARE} ${PORTNAME} \
diff --git a/math/glm/distinfo b/math/glm/distinfo
index 56b096ac3fe7..3cdd7a37118b 100644
--- a/math/glm/distinfo
+++ b/math/glm/distinfo
@@ -1,2 +1,2 @@
-SHA256 (glm-0.9.6.3.zip) = 14651b56b10fa68082446acaf6a1116d56b757c8d375b34b5226a83140acd2b2
-SIZE (glm-0.9.6.3.zip) = 4233404
+SHA256 (g-truc-glm-0.9.7.1_GH0.tar.gz) = 285a0dc8f762b4e523c8710fbd97accaace0c61f45bc8be2bdb0deed07b0e6f3
+SIZE (g-truc-glm-0.9.7.1_GH0.tar.gz) = 3453078
diff --git a/math/glm/pkg-plist b/math/glm/pkg-plist
index c51b1270e742..5b22b9d1314c 100644
--- a/math/glm/pkg-plist
+++ b/math/glm/pkg-plist
@@ -17,8 +17,6 @@ include/glm/detail/func_integer.hpp
include/glm/detail/func_integer.inl
include/glm/detail/func_matrix.hpp
include/glm/detail/func_matrix.inl
-include/glm/detail/func_noise.hpp
-include/glm/detail/func_noise.inl
include/glm/detail/func_packing.hpp
include/glm/detail/func_packing.inl
include/glm/detail/func_trigonometric.hpp
@@ -88,6 +86,8 @@ include/glm/geometric.hpp
include/glm/glm.hpp
include/glm/gtc/bitfield.hpp
include/glm/gtc/bitfield.inl
+include/glm/gtc/color_space.hpp
+include/glm/gtc/color_space.inl
include/glm/gtc/constants.hpp
include/glm/gtc/constants.inl
include/glm/gtc/epsilon.hpp
@@ -155,6 +155,8 @@ include/glm/gtx/gradient_paint.hpp
include/glm/gtx/gradient_paint.inl
include/glm/gtx/handed_coordinate_space.hpp
include/glm/gtx/handed_coordinate_space.inl
+include/glm/gtx/hash.hpp
+include/glm/gtx/hash.inl
include/glm/gtx/integer.hpp
include/glm/gtx/integer.inl
include/glm/gtx/intersect.hpp
@@ -179,8 +181,6 @@ include/glm/gtx/matrix_transform_2d.hpp
include/glm/gtx/matrix_transform_2d.inl
include/glm/gtx/mixed_product.hpp
include/glm/gtx/mixed_product.inl
-include/glm/gtx/multiple.hpp
-include/glm/gtx/multiple.inl
include/glm/gtx/norm.hpp
include/glm/gtx/norm.inl
include/glm/gtx/normal.hpp