aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
Diffstat (limited to 'math')
-rw-r--r--math/singular/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/math/singular/Makefile b/math/singular/Makefile
index d23f43af35ca..ef2fe58189a9 100644
--- a/math/singular/Makefile
+++ b/math/singular/Makefile
@@ -2,6 +2,7 @@
PORTNAME= singular
PORTVERSION= 4.1.1
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= http://www.mathematik.uni-kl.de/ftp/pub/Math/Singular/SOURCES/4-1-1/
@@ -14,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libgmp.so:math/gmp \
libmpfr.so:math/mpfr
-USES= gmake libtool perl5 pkgconfig shebangfix
+USES= gmake libtool ncurses perl5 pkgconfig shebangfix
USE_PERL5= build
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
@@ -23,4 +24,10 @@ MAKE_JOBS_UNSAFE= yes
SHEBANG_FILES= libpolys/libpolys-config.in \
libsingular-config.in
+# not a shebang but "/bin/bash" is hardcoded in some files
+post-patch:
+ @${REINPLACE_CMD} -e "s|/bin/bash|${LOCALBASE}/bin/bash|g" \
+ ${WRKSRC}/emacs/.emacs-general
+
+
.include <bsd.port.mk>