aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
Diffstat (limited to 'math')
-rw-r--r--math/GiNaC/Makefile2
-rw-r--r--math/algae/Makefile2
-rw-r--r--math/asir2000/Makefile2
-rw-r--r--math/blitz++/Makefile2
-rw-r--r--math/cln/Makefile2
-rw-r--r--math/dieharder/Makefile2
-rw-r--r--math/fftw/Makefile2
-rw-r--r--math/fityk/Makefile2
-rw-r--r--math/freefem/Makefile2
-rw-r--r--math/fung-calc/Makefile2
-rw-r--r--math/gambit/Makefile2
-rw-r--r--math/gcalctool/Makefile2
-rw-r--r--math/geg/Makefile2
-rw-r--r--math/gnuplot+/Makefile2
-rw-r--r--math/gretl/Makefile2
-rw-r--r--math/guppi/Makefile2
-rw-r--r--math/koctave/Makefile2
-rw-r--r--math/labplot/Makefile2
-rw-r--r--math/liblbfgs/Makefile2
-rw-r--r--math/libmath++/Makefile4
-rw-r--r--math/libneural/Makefile2
-rw-r--r--math/libqalculate/Makefile2
-rw-r--r--math/ltl/Makefile2
-rw-r--r--math/maxima/Makefile2
-rw-r--r--math/octave-devel/Makefile2
-rw-r--r--math/octave/Makefile2
-rw-r--r--math/oleo/Makefile2
-rw-r--r--math/pgcalc/Makefile2
-rw-r--r--math/plplot/Makefile2
-rw-r--r--math/pspp/Makefile2
-rw-r--r--math/qhull/Makefile2
-rw-r--r--math/qhull5/Makefile2
-rw-r--r--math/rkward/Makefile2
-rw-r--r--math/saga/Makefile2
-rw-r--r--math/spar/Makefile2
-rw-r--r--math/tvmet/Makefile2
-rw-r--r--math/yacas/Makefile2
37 files changed, 38 insertions, 38 deletions
diff --git a/math/GiNaC/Makefile b/math/GiNaC/Makefile
index 9949e9918bf3..d2a329041aac 100644
--- a/math/GiNaC/Makefile
+++ b/math/GiNaC/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= cln.6:${PORTSDIR}/math/cln
USE_BZIP2= yes
USE_GNOME= gnomehack pkgconfig
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:22
+USE_AUTOTOOLS= libtool
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
USE_LDCONFIG= yes
diff --git a/math/algae/Makefile b/math/algae/Makefile
index 3e6a9a9fc2f8..bb52f788dee0 100644
--- a/math/algae/Makefile
+++ b/math/algae/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A programming language for numerical analysis
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= autoconf:268
+USE_AUTOTOOLS= autoconf
ALGAE_VERSION= ${PORTVERSION}
PLIST_SUB= ALGAE_VERSION=${ALGAE_VERSION}
diff --git a/math/asir2000/Makefile b/math/asir2000/Makefile
index 059a5c684c32..30767ee54685 100644
--- a/math/asir2000/Makefile
+++ b/math/asir2000/Makefile
@@ -24,7 +24,7 @@ LIB_DEPENDS= pari-gmp.2:${PORTSDIR}/math/pari
USE_XORG= x11 xaw xext xt
GNU_CONFIGURE= yes
-#XXX USE_AUTOTOOLS= automake:111 autoconf:268
+#XXX USE_AUTOTOOLS= automake autoconf
CONFIGURE_ARGS= --enable-shared --enable-plot --enable-fep --enable-interval --with-pari
ASIR_SRC_VERSION= ${PORTVERSION}
ASIR_DOC_VERSION= 20070718
diff --git a/math/blitz++/Makefile b/math/blitz++/Makefile
index 27523fdbeaef..1517ddf77566 100644
--- a/math/blitz++/Makefile
+++ b/math/blitz++/Makefile
@@ -24,7 +24,7 @@ MAKE_ARGS= NOPORTDOCS=yes
.endif
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:22
+USE_AUTOTOOLS= libtool
USE_GNOME= gnometarget gnomehack
CONFIGURE_ARGS= --with-cxx=gcc --disable-doxygen
MAKE_ARGS+= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
diff --git a/math/cln/Makefile b/math/cln/Makefile
index 9ac05747f8cb..d56c03cbdcca 100644
--- a/math/cln/Makefile
+++ b/math/cln/Makefile
@@ -19,7 +19,7 @@ COMMENT= Class Library for Numbers
LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp
-USE_AUTOTOOLS= libtool:22
+USE_AUTOTOOLS= libtool
USE_BZIP2= yes
USE_GNOME= gnomehack gnometarget pkgconfig
USE_GMAKE= yes
diff --git a/math/dieharder/Makefile b/math/dieharder/Makefile
index 41510124910c..ea9acf0d45a9 100644
--- a/math/dieharder/Makefile
+++ b/math/dieharder/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= gsl:${PORTSDIR}/math/gsl
MAKE_JOBS_UNSAFE= yes
USE_DOS2UNIX= yes
-USE_AUTOTOOLS= aclocal:111 autoheader:268 libtool:22
+USE_AUTOTOOLS= aclocal autoheader libtool
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
diff --git a/math/fftw/Makefile b/math/fftw/Makefile
index 25fb54caa35b..fb50d7f32a7e 100644
--- a/math/fftw/Makefile
+++ b/math/fftw/Makefile
@@ -22,7 +22,7 @@ COMMENT?= Fast C routines to compute the Discrete Fourier Transform
FFTW_FLAVOR?= default
FFTW_SUFIX=
-USE_AUTOTOOLS= libtool:22
+USE_AUTOTOOLS= libtool
USE_FORTRAN= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/math/fityk/Makefile b/math/fityk/Makefile
index 07cdc77019fa..031be912ea8b 100644
--- a/math/fityk/Makefile
+++ b/math/fityk/Makefile
@@ -29,7 +29,7 @@ USE_GNOME= gtk20
USE_WX= 2.8+
WX_CONF_ARGS= absolute
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:22
+USE_AUTOTOOLS= libtool
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --without-doc --disable-xyconvert
USE_LDCONFIG= yes
diff --git a/math/freefem/Makefile b/math/freefem/Makefile
index ecb48d4b078e..0f71134741cf 100644
--- a/math/freefem/Makefile
+++ b/math/freefem/Makefile
@@ -16,7 +16,7 @@ COMMENT= A language for the Finite Element Method
USE_XORG= ice sm x11 xt
USE_GNOME= gnometarget
-USE_AUTOTOOLS= libtool:22
+USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
MAN1= freefem.1
diff --git a/math/fung-calc/Makefile b/math/fung-calc/Makefile
index 6a42edeb57fe..11ed784bbca4 100644
--- a/math/fung-calc/Makefile
+++ b/math/fung-calc/Makefile
@@ -17,7 +17,7 @@ USE_KDELIBS_VER=3
USE_GL= glut
USE_GMAKE= yes
USE_LDCONFIG= yes
-USE_AUTOTOOLS= libtool:22
+USE_AUTOTOOLS= libtool
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
pre-configure:
diff --git a/math/gambit/Makefile b/math/gambit/Makefile
index 27a4363c7c16..2721004a2614 100644
--- a/math/gambit/Makefile
+++ b/math/gambit/Makefile
@@ -17,7 +17,7 @@ COMMENT= A library of tools for doing computation in game theory
USE_GNOME= gnometarget gtk20
WANT_UNICODE= yes
USE_WX= 2.6+
-USE_AUTOTOOLS= libtool:22
+USE_AUTOTOOLS= libtool
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS+=--with-wx-config=${WX_CONFIG}
USE_LDCONFIG= yes
diff --git a/math/gcalctool/Makefile b/math/gcalctool/Makefile
index 82ce94a32a0d..874fe82d50f4 100644
--- a/math/gcalctool/Makefile
+++ b/math/gcalctool/Makefile
@@ -22,7 +22,7 @@ USE_BZIP2= yes
USE_BISON= build
USE_GETTEXT= yes
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:22
+USE_AUTOTOOLS= libtool
USE_GNOME= gnomeprefix gnomehack intlhack gconf2 gnomedocutils gtk20
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/math/geg/Makefile b/math/geg/Makefile
index a9018f2fc019..a48e80035177 100644
--- a/math/geg/Makefile
+++ b/math/geg/Makefile
@@ -17,7 +17,7 @@ MAINTAINER= domi@saargate.de
COMMENT= Visualise multiple 2D-functions of one variable
USE_GNOME= gtk12
-USE_AUTOTOOLS= automake:111 autoconf:268
+USE_AUTOTOOLS= automake autoconf
AUTOMAKE_ARGS= -a -i
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
diff --git a/math/gnuplot+/Makefile b/math/gnuplot+/Makefile
index 736693d7972e..58562a6b6235 100644
--- a/math/gnuplot+/Makefile
+++ b/math/gnuplot+/Makefile
@@ -26,7 +26,7 @@ LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png \
USE_XORG= x11
USE_FREETYPE= yes
USE_GMAKE= yes
-USE_AUTOTOOLS= autoconf:213
+USE_AUTOTOOLS= autoconf213
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --exec-prefix=${PREFIX} \
--includedir=${LOCALBASE}/include/ \
diff --git a/math/gretl/Makefile b/math/gretl/Makefile
index 980508e6c2a8..c59d4dc7f222 100644
--- a/math/gretl/Makefile
+++ b/math/gretl/Makefile
@@ -23,7 +23,7 @@ USE_BZIP2= yes
USE_GNOME= gnomehier gtk20 gtksourceview2 libxml2
USE_GETTEXT= yes
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:22
+USE_AUTOTOOLS= libtool
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib ${GCCLIBDIR}"
CONFIGURE_ARGS= --enable-static --enable-shared --with-gmake --without-gnome
diff --git a/math/guppi/Makefile b/math/guppi/Makefile
index ac2453e6601d..f6693b7ac246 100644
--- a/math/guppi/Makefile
+++ b/math/guppi/Makefile
@@ -22,7 +22,7 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack gnomelibs bonobo libglade gal gnometarget
USE_PYTHON= yes
-USE_AUTOTOOLS= libtool:22
+USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-gnumeric --enable-explicit-python-linking
diff --git a/math/koctave/Makefile b/math/koctave/Makefile
index c4df82f0deb6..b300fbdcc417 100644
--- a/math/koctave/Makefile
+++ b/math/koctave/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= octave:${PORTSDIR}/math/octave
USE_QT_VER= 3
USE_KDELIBS_VER=3
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:22
+USE_AUTOTOOLS= libtool
post-patch:
${REINPLACE_CMD} -e '/kde_appsdir/s|applnk||g' ${WRKSRC}/configure
diff --git a/math/labplot/Makefile b/math/labplot/Makefile
index 4e08a03adee2..74a688294f10 100644
--- a/math/labplot/Makefile
+++ b/math/labplot/Makefile
@@ -27,7 +27,7 @@ USE_QT_VER= 3
USE_KDELIBS_VER=3
USE_GL= glu
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:22
+USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
USE_GETTEXT= yes
diff --git a/math/liblbfgs/Makefile b/math/liblbfgs/Makefile
index b4a0c7beb97f..3c2311e3338a 100644
--- a/math/liblbfgs/Makefile
+++ b/math/liblbfgs/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= gaod@hychen.org
COMMENT= A library of Limited-memory Broyden-Fletcher-Goldfarb-Shanno
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= autoconf:268:en
+USE_AUTOTOOLS= autoconf:env
OPTIONS= OPTIMIZED "Enable SSE2 optimization routines" Off
diff --git a/math/libmath++/Makefile b/math/libmath++/Makefile
index 19c5a1c0eb97..1a2291945d42 100644
--- a/math/libmath++/Makefile
+++ b/math/libmath++/Makefile
@@ -13,9 +13,9 @@ MASTER_SITES= http://www.robertjohnkaper.com/downloads/atlantik/
MAINTAINER= jhb@FreeBSD.org
COMMENT= C++ Library for Symbolic and Numeric Calculus Applications
-USE_AUTOTOOLS= libtool:22
+USE_AUTOTOOLS= libtool
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:22
+USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/math/libneural/Makefile b/math/libneural/Makefile
index 702e98f4179e..3d140d8fe441 100644
--- a/math/libneural/Makefile
+++ b/math/libneural/Makefile
@@ -14,7 +14,7 @@ MASTER_SITES= http://www.freebsdbrasil.com.br/~jmelo/
MAINTAINER= ports@FreeBSD.org
COMMENT= C++ implementation of the classic 3-layer perceptron in library form
-USE_AUTOTOOLS= libtool:22
+USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/math/libqalculate/Makefile b/math/libqalculate/Makefile
index 4a67ad4b8f8a..1d577e373613 100644
--- a/math/libqalculate/Makefile
+++ b/math/libqalculate/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= cln.6:${PORTSDIR}/math/cln
USE_GNOME= glib20 gnomehack gnometarget intlhack libxml2
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:22
+USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
.if !defined(WITHOUT_NLS)
diff --git a/math/ltl/Makefile b/math/ltl/Makefile
index a040a8eedcc6..cd8b3f30202f 100644
--- a/math/ltl/Makefile
+++ b/math/ltl/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= lapack.4:${PORTSDIR}/math/lapack \
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= libtool:22
+USE_AUTOTOOLS= libtool
CONFIGURE_ARGS= --with-cxx=gcc --disable-doxygen --prefix=${PREFIX} --includedir=${PREFIX}/include/LTL
MAKE_ENV= prefix=${PREFIX} exec_prefix=${PREFIX}
MAKE_ARGS+= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
diff --git a/math/maxima/Makefile b/math/maxima/Makefile
index c550a30561a4..3c52f575a6a2 100644
--- a/math/maxima/Makefile
+++ b/math/maxima/Makefile
@@ -24,7 +24,7 @@ LICENSE= GPLv2
USE_TK = 84+
USE_GMAKE= yes
USE_PERL5_BUILD= yes
-USE_AUTOTOOLS= aclocal:111 autoconf:268
+USE_AUTOTOOLS= aclocal autoconf
CONFIGURE_ARGS+= --prefix=${PREFIX} \
--with-posix-shell=${LOCALBASE}/bin/bash \
--with-wish=${WISH} \
diff --git a/math/octave-devel/Makefile b/math/octave-devel/Makefile
index 56c75e480862..46a5f554cf49 100644
--- a/math/octave-devel/Makefile
+++ b/math/octave-devel/Makefile
@@ -35,7 +35,7 @@ USE_BZIP2= yes
USE_PERL5_BUILD=yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= autoconf:268 autoheader:268
+USE_AUTOTOOLS= autoconf autoheader
INFO= liboctave
MAN1= octave.1 octave-bug.1 mkoctfile.1 octave-config.1
diff --git a/math/octave/Makefile b/math/octave/Makefile
index a6a4757a6ca3..76afa312cd8d 100644
--- a/math/octave/Makefile
+++ b/math/octave/Makefile
@@ -37,7 +37,7 @@ USE_BZIP2= yes
USE_PERL5_BUILD=yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= autoconf:268
+USE_AUTOTOOLS= autoconf
INFO= octave liboctave
MAN1= octave.1 octave-bug.1 mkoctfile.1 octave-config.1
diff --git a/math/oleo/Makefile b/math/oleo/Makefile
index b52fa541dfd7..46036b6c6093 100644
--- a/math/oleo/Makefile
+++ b/math/oleo/Makefile
@@ -17,7 +17,7 @@ COMMENT= The GNU spreadsheet for X11 and terminals
USE_PERL5_BUILD= yes
USE_BISON= build
-USE_AUTOTOOLS= autoconf:213
+USE_AUTOTOOLS= autoconf213
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-x --without-xlt --without-SciPlot
diff --git a/math/pgcalc/Makefile b/math/pgcalc/Makefile
index 24befa1e83fd..d0cde38f0301 100644
--- a/math/pgcalc/Makefile
+++ b/math/pgcalc/Makefile
@@ -17,7 +17,7 @@ COMMENT= A powerful scientific skinnable calculator
USE_QT_VER= 3
USE_KDELIBS_VER= 3
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:22
+USE_AUTOTOOLS= libtool
INSTALLS_ICONS= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/math/plplot/Makefile b/math/plplot/Makefile
index f6e7b7595379..9f372008d74c 100644
--- a/math/plplot/Makefile
+++ b/math/plplot/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= unicode.0:${PORTSDIR}/devel/libunicode \
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash \
${LOCALBASE}/lib/X11/fonts/freefont-ttf/FreeMono.ttf:${PORTSDIR}/x11-fonts/freefont-ttf
-USE_AUTOTOOLS= libltdl:22
+USE_AUTOTOOLS= libltdl
USE_CMAKE= yes
USE_GMAKE= yes
USE_PERL5_BUILD=yes
diff --git a/math/pspp/Makefile b/math/pspp/Makefile
index 0f9765188dbe..fd2be950e084 100644
--- a/math/pspp/Makefile
+++ b/math/pspp/Makefile
@@ -24,7 +24,7 @@ USE_GNOME= libxml2
USE_PERL5_BUILD=yes
USE_ICONV= yes
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:22
+USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
diff --git a/math/qhull/Makefile b/math/qhull/Makefile
index 351379e9bd6b..f6a71a3bfa65 100644
--- a/math/qhull/Makefile
+++ b/math/qhull/Makefile
@@ -18,7 +18,7 @@ PATCH_SITES= http://www.qhull.org/download/
PATCHFILES= poly.c-qh_gethash.patch
PATCH_DIST_STRIP= -p2
-USE_AUTOTOOLS= libtool:22
+USE_AUTOTOOLS= libtool
USE_GMAKE= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/math/qhull5/Makefile b/math/qhull5/Makefile
index 351379e9bd6b..f6a71a3bfa65 100644
--- a/math/qhull5/Makefile
+++ b/math/qhull5/Makefile
@@ -18,7 +18,7 @@ PATCH_SITES= http://www.qhull.org/download/
PATCHFILES= poly.c-qh_gethash.patch
PATCH_DIST_STRIP= -p2
-USE_AUTOTOOLS= libtool:22
+USE_AUTOTOOLS= libtool
USE_GMAKE= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/math/rkward/Makefile b/math/rkward/Makefile
index ece90111e569..bb9dde071552 100644
--- a/math/rkward/Makefile
+++ b/math/rkward/Makefile
@@ -23,7 +23,7 @@ USE_KDELIBS_VER=3
USE_PHP= yes
WANT_PHP_CLI= yes
USE_GETTEXT= yes
-USE_AUTOTOOLS= libtool:22
+USE_AUTOTOOLS= libtool
CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
CONFIGURE_ARGS= --disable-fast-perl
diff --git a/math/saga/Makefile b/math/saga/Makefile
index fb77a9f9e3ce..366213d3e5e5 100644
--- a/math/saga/Makefile
+++ b/math/saga/Makefile
@@ -24,7 +24,7 @@ LIB_DEPENDS= proj.6:${PORTSDIR}/graphics/proj \
USE_WX= 2.8
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= libtool:22
+USE_AUTOTOOLS= libtool
CFLAGS+= -I${LOCALBASE}/include
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_DOS2UNIX= dlg_about.cpp
diff --git a/math/spar/Makefile b/math/spar/Makefile
index fdf0fbb9dd96..f49b5501464a 100644
--- a/math/spar/Makefile
+++ b/math/spar/Makefile
@@ -15,7 +15,7 @@ MASTER_SITES= SF/${PORTNAME}/Spar/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A modular math parser
-USE_AUTOTOOLS= libtool:22
+USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/math/tvmet/Makefile b/math/tvmet/Makefile
index 350daa8eb688..8c5a501f394d 100644
--- a/math/tvmet/Makefile
+++ b/math/tvmet/Makefile
@@ -16,7 +16,7 @@ COMMENT= Tiny Vector and Matrix template library
USE_BZIP2= yes
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:22
+USE_AUTOTOOLS= libtool
MAKE_ARGS= CXX="${CXX}" CXXFLAGS="${CXXFLAGS}"
MAN1= tvmet-config.1
diff --git a/math/yacas/Makefile b/math/yacas/Makefile
index 403ff71201ca..239912ee8aa6 100644
--- a/math/yacas/Makefile
+++ b/math/yacas/Makefile
@@ -15,7 +15,7 @@ MASTER_SITES= http://yacas.sourceforge.net/backups/
MAINTAINER= ports@FreeBSD.org
COMMENT= Yet Another Computer Algebra System
-USE_AUTOTOOLS= libtool:22
+USE_AUTOTOOLS= libtool
USE_PERL5_BUILD= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes