aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/pecl-trader/Makefile22
-rw-r--r--math/pecl-trader/distinfo2
-rw-r--r--math/pecl-trader/pkg-descr8
4 files changed, 33 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 4af6facd9c01..56703b51fa6b 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -520,6 +520,7 @@
SUBDIR += pecl-big_int
SUBDIR += pecl-bitset
SUBDIR += pecl-stats
+ SUBDIR += pecl-trader
SUBDIR += petsc
SUBDIR += php5-bcmath
SUBDIR += php5-gmp
diff --git a/math/pecl-trader/Makefile b/math/pecl-trader/Makefile
new file mode 100644
index 000000000000..63d4259635b6
--- /dev/null
+++ b/math/pecl-trader/Makefile
@@ -0,0 +1,22 @@
+# Created by: Jim Ohlstein <jim@ohlste.in>
+# $FreeBSD$
+
+PORTNAME= trader
+PORTVERSION= 0.3.0
+CATEGORIES= math devel
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
+
+MAINTAINER= jim@ohlste.in
+COMMENT= Trader extension based on TA-Lib
+
+LICENSE= BSD2CLAUSE
+
+USE_PHP= yes
+USE_PHPEXT= yes
+
+IGNORE_WITH_PHP= 52
+
+.include <bsd.port.mk>
diff --git a/math/pecl-trader/distinfo b/math/pecl-trader/distinfo
new file mode 100644
index 000000000000..5292200d1ab1
--- /dev/null
+++ b/math/pecl-trader/distinfo
@@ -0,0 +1,2 @@
+SHA256 (PECL/trader-0.3.0.tgz) = 430763a44f6e81402b87cf84833a721a697efa5f8043de8a7e855b2221a4b132
+SIZE (PECL/trader-0.3.0.tgz) = 295748
diff --git a/math/pecl-trader/pkg-descr b/math/pecl-trader/pkg-descr
new file mode 100644
index 000000000000..68dc0e968ca2
--- /dev/null
+++ b/math/pecl-trader/pkg-descr
@@ -0,0 +1,8 @@
+The trader extension is a free open source stock library based on TA-Lib.
+It's dedicated to trading software developers requiring to perform technical
+analysis of financial market data. Alongside many indicators like ADX, MACD,
+RSI, Stochastic, TRIX the candlestick pattern recognition and several vector
+arithmetic and algebraic functions are present.
+
+
+WWW: http://pecl.php.net/package/trader/