aboutsummaryrefslogtreecommitdiffstats
path: root/mbone/sdr/files/Makefile.freebsd
diff options
context:
space:
mode:
Diffstat (limited to 'mbone/sdr/files/Makefile.freebsd')
-rw-r--r--mbone/sdr/files/Makefile.freebsd8
1 files changed, 8 insertions, 0 deletions
diff --git a/mbone/sdr/files/Makefile.freebsd b/mbone/sdr/files/Makefile.freebsd
new file mode 100644
index 000000000000..3022704ab5f3
--- /dev/null
+++ b/mbone/sdr/files/Makefile.freebsd
@@ -0,0 +1,8 @@
+CC = gcc -g -O
+INCLUDES = -I${X11BASE}/include -I${LOCALBASE}/include/tk8.0 -I${LOCALBASE}/include/tcl8.0 -I${LOCALBASE}/include/uclmmbase
+LIBS = -L${LOCALBASE}/lib -ltk80 -ltcl80 -luclmmbase -L${X11BASE}/lib -lX11 -lz -lm
+CFLAGS = $(INCLUDES) -DDIFF_BYTE_ORDER -DFREEBSD -DNORANDPROTO -DDEFINED_ERRLIST -Wall -DAUTH -DHAVE_ZLIB -DFreeBSD
+
+all:: sdr
+install:
+ install -s -c -o root -g wheel -m 555 sdr ${PREFIX}/bin