aboutsummaryrefslogtreecommitdiffstats
path: root/misc/dahdi-kmod/files/patch-tools-Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/dahdi-kmod/files/patch-tools-Makefile')
-rw-r--r--misc/dahdi-kmod/files/patch-tools-Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/misc/dahdi-kmod/files/patch-tools-Makefile b/misc/dahdi-kmod/files/patch-tools-Makefile
new file mode 100644
index 000000000000..4cd89f5d414f
--- /dev/null
+++ b/misc/dahdi-kmod/files/patch-tools-Makefile
@@ -0,0 +1,40 @@
+--- tools/Makefile.orig 2009-11-04 22:36:21.000000000 +0600
++++ tools/Makefile 2010-03-03 17:36:39.000000000 +0600
+@@ -27,7 +27,7 @@
+ endif
+
+ SUBDIRS_UTILS_ALL:= ppp
+-SUBDIRS_UTILS := xpp
++#SUBDIRS_UTILS := xpp
+
+ OPTFLAGS=-O2
+ CFLAGS+=-I. $(OPTFLAGS) -g -fPIC -Wall -DBUILDING_TONEZONE #-DTONEZONE_DRIVER
+@@ -229,13 +229,13 @@
+ install -d $(DESTDIR)$(MAN_DIR)
+ install -m 644 $(MAN_PAGES) $(DESTDIR)$(MAN_DIR)/
+ endif
+-ifeq (,$(wildcard $(DESTDIR)$(CONFIG_FILE)))
+- $(INSTALL) -D -m 644 system.conf.sample $(DESTDIR)$(CONFIG_FILE)
+-endif
++ $(INSTALL) -d -m755 $(DESTDIR)$(CONFIG_DIR)
++ $(INSTALL) -m 644 system.conf.sample $(DESTDIR)$(CONFIG_DIR)
+
+ install-libs: libs
+- $(INSTALL) -D -m 755 $(LTZ_A) $(DESTDIR)$(LIB_DIR)/$(LTZ_A)
+- $(INSTALL) -D -m 755 $(LTZ_SO) $(DESTDIR)$(LIB_DIR)/$(LTZ_SO).$(LTZ_SO_MAJOR_VER).$(LTZ_SO_MINOR_VER)
++ $(INSTALL) -d -m755 $(DESTDIR)$(LIB_DIR)
++ $(INSTALL) -m 755 $(LTZ_A) $(DESTDIR)$(LIB_DIR)/$(LTZ_A)
++ $(INSTALL) -m 755 $(LTZ_SO) $(DESTDIR)$(LIB_DIR)/$(LTZ_SO).$(LTZ_SO_MAJOR_VER).$(LTZ_SO_MINOR_VER)
+ ifeq (,$(DESTDIR))
+ if [ `id -u` = 0 ]; then \
+ /sbin/ldconfig || : ;\
+@@ -260,7 +260,8 @@
+ /sbin/restorecon -v $(DESTDIR)$(LIB_DIR)/$(LTZ_SO)
+ endif
+ endif
+- $(INSTALL) -D -m 644 tonezone.h $(DESTDIR)$(INC_DIR)/tonezone.h
++ $(INSTALL) -d -m755 $(DESTDIR)$(INC_DIR)
++ $(INSTALL) -m 644 tonezone.h $(DESTDIR)$(INC_DIR)/tonezone.h
+
+ install-utils-subdirs:
+ @for dir in $(SUBDIRS_UTILS); do \