aboutsummaryrefslogtreecommitdiffstats
path: root/misc/iselect/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/iselect/Makefile')
-rw-r--r--misc/iselect/Makefile20
1 files changed, 9 insertions, 11 deletions
diff --git a/misc/iselect/Makefile b/misc/iselect/Makefile
index 98aba6ee9c00..96a30acadf97 100644
--- a/misc/iselect/Makefile
+++ b/misc/iselect/Makefile
@@ -4,24 +4,24 @@
PORTNAME= iselect
PORTVERSION= 1.4.0
CATEGORIES= misc
-MASTER_SITES= ${MASTER_SITE_OSSP}
+MASTER_SITES= OSSP
MASTER_SITE_SUBDIR= tool/iselect
MAINTAINER= ports@FreeBSD.org
COMMENT= Interactive Selection Tool
-OPTIONS_DEFINE= SLANG
+OPTIONS_DEFINE= SLANG EXAMPLES
SLANG_DESC= Link with slang
GNU_CONFIGURE= yes
-MAN1= iselect.1
+PLIST_FILES= bin/iselect man/man1/iselect.1.gz
+PORTEXAMPLES= *
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MSLANG}
-LIB_DEPENDS+= slang.2:${PORTSDIR}/devel/libslang2
+LIB_DEPENDS+= libslang.so:${PORTSDIR}/devel/libslang2
CONFIGURE_ARGS+= --with-incdir=${LOCALBASE}/include \
--with-libdir=${LOCALBASE}/lib
.endif
@@ -30,12 +30,10 @@ post-patch:
@${REINPLACE_CMD} -e 's|^CFLAGS=|#CFLAGS=|g' ${WRKSRC}/configure
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/iselect ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/iselect.1 ${MANPREFIX}/man/man1
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/iselect ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/iselect.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
cd ${WRKSRC}/example && ${FIND} . | \
- ${CPIO} -pdm -L -R ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
-.endif
+ ${CPIO} -pdm -L -R ${SHAREOWN}:${SHAREGRP} ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>