aboutsummaryrefslogtreecommitdiffstats
path: root/misc/kdeutils4/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/kdeutils4/Makefile')
-rw-r--r--misc/kdeutils4/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/misc/kdeutils4/Makefile b/misc/kdeutils4/Makefile
index 3ce4d66bd60b..1725a3ae4156 100644
--- a/misc/kdeutils4/Makefile
+++ b/misc/kdeutils4/Makefile
@@ -7,6 +7,7 @@
PORTNAME= kdeutils
PORTVERSION= ${KDE_VERSION}
+PORTREVISION= 1
CATEGORIES?= misc kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
@@ -25,13 +26,20 @@ MAN1= efax.1 efix.1 fax.1
#klaptop doesn't like alpha because alpha doesn't support apm
.if ${MACHINE_ARCH} == "alpha"
-post-extract:
- mv ${WRKSRC}/subdirs ${WRKSRC}/subdirs.orig
- grep -v klaptopdaemon ${WRKSRC}/subdirs.orig > ${WRKSRC}/subdirs
-
+DO_NOT_COMPILE+=klaptopdaemon
PLIST_SUB+= ALPHA_NA="@comment "
.else
PLIST_SUB+= ALPHA_NA=""
.endif
+# kfloppy is a mostly broken, non-standard, linux-centric pain...
+.if !defined(WITH_KFLOPPY)
+DO_NOT_COMPILE+=kfloppy
+PLIST_SUB+= KFLOPPY="@comment "
+.else
+PLIST_SUB+= KFLOPPY=""
+.endif
+.if defined(DO_NOT_COMPILE)
+CONFIGURE_ENV+= DO_NOT_COMPILE="${DO_NOT_COMPILE}"
+.endif
.include <bsd.port.mk>