aboutsummaryrefslogtreecommitdiffstats
path: root/misc/krecipes/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/krecipes/Makefile')
-rw-r--r--misc/krecipes/Makefile42
1 files changed, 19 insertions, 23 deletions
diff --git a/misc/krecipes/Makefile b/misc/krecipes/Makefile
index b4e237948781..16975e1d16a7 100644
--- a/misc/krecipes/Makefile
+++ b/misc/krecipes/Makefile
@@ -1,58 +1,54 @@
-# ports collection makefile for: krecipies
-# Date created: 19 March 2005
-# Whom: hank
+# ports collection makefile for: krecipies
+# Date created: 19 March 2005
+# Whom: hank
#
# $FreeBSD$
#
PORTNAME= krecipes
-PORTVERSION= 0.7.1
-PORTREVISION= 1
+PORTVERSION= 0.9.1
CATEGORIES= misc kde
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= krecipes_beta_0.7.1
MAINTAINER= hank@millerfarm.com
COMMENT= Recipe database for cooks
-OPTIONS+= SQLITE "Support for sqlite backend" on
-OPTIONS+= MYSQL "Support for MySQL backend" off
-OPTIONS+= POSTGRESQL "Support for PostgreSQL backend" off
-
-USE_KDELIBS_VER= 3
+USE_KDELIBS_VER=3
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
-WRKSRC= ${WRKDIR}/krecipes-0.7.1
-
-INSTALLS_SHLIB= yes
+OPTIONS= SQLITE "Support for SQLite backend" on \
+ MYSQL "Support for MySQL backend" off \
+ POSTGRESQL "Support for PostgreSQL backend" off
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-BROKEN= Does not compile.
-.endif
-
.if defined(WITHOUT_SQLITE)
CONFIGURE_ARGS+= --without-sqlite
-PLIST_SUB+= SQLITE="@comment "
.else
-LIB_DEPENDS+= sqlite3:${PORTSDIR}/databases/sqlite3
-PLIST_SUB+= SQLITE=""
+USE_SQLITE= yes
.endif
.if defined(WITH_MYSQL)
RUN_DEPENDS+= ${X11BASE}/lib/plugins/sqldrivers/libqsqlmysql.so:${PORTSDIR}/databases/qt-mysql-plugin
+.else
+CONFIGURE_ARGS+= --without-mysql
.endif
.if defined(WITH_POSTGRESQL)
RUN_DEPENDS+= ${X11BASE}/lib/plugins/sqldrivers/libqsqlpsql.so:${PORTSDIR}/databases/qt-pgsql-plugin
+.else
+CONFIGURE_ARGS+= --without-postgresql
.endif
+post-extract:
+ @${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/${CONFIGURE_SCRIPT}
+
pre-configure:
-. if defined(WITHOUT_SQLITE) && !defined(WITH_MYSQL) && !defined(WITH_POSTGRESQL)
+.if defined(WITHOUT_SQLITE) && !defined(WITH_MYSQL) && !defined(WITH_POSTGRESQL)
@${ECHO} "You must have at least one database backend"
@exit 1
-. endif
+.endif
.include <bsd.port.post.mk>