aboutsummaryrefslogtreecommitdiffstats
path: root/misc/magicpoint/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/magicpoint/Makefile')
-rw-r--r--misc/magicpoint/Makefile50
1 files changed, 44 insertions, 6 deletions
diff --git a/misc/magicpoint/Makefile b/misc/magicpoint/Makefile
index b640c3750ae0..38209faef27b 100644
--- a/misc/magicpoint/Makefile
+++ b/misc/magicpoint/Makefile
@@ -7,9 +7,9 @@
# "?=" and "+=" are for localized (i.e. Japanese) version
PORTNAME= magicpoint
-PORTVERSION= 1.11a
+PORTVERSION= 1.11b
CATEGORIES+= misc
-MASTER_SITES= ftp://ftp.mew.org/pub/mgp/
+MASTER_SITES= ftp://sh.wide.ad.jp/WIDE/free-ware/mgp/
MAINTAINER?= mita@FreeBSD.org
COMMENT?= An X11-based presentation tool
@@ -18,13 +18,14 @@ LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png \
mng:${PORTSDIR}/graphics/libmng
RUN_DEPENDS+= pnmscale:${PORTSDIR}/graphics/netpbm
-BROKEN= Incomplete pkg-plist
-
USE_IMAKE= yes
USE_REINPLACE= yes
-USE_FREETYPE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS?=--disable-vflib
+
+OPTIONS+= FREETYPE "With FreeType support" on \
+ XFT "With Xft2 support" on \
+ GIF "With gif image support" off \
+ IMLIB "With Imlib exclusive image processing" off
MAN1= mgp.1 mgp2ps.1 mgpembed.1 mgpnet.1 xwintoppm.1 xmindpath.1
@@ -43,6 +44,43 @@ SAMPLE_SCRIPTS= eqn2eps.sh tex2eps.sh mgp2html.pl mgp2latex.pl
.include <bsd.port.pre.mk>
+.if defined(WITH_FREETYPE)
+USE_FREETYPE= yes
+CONFIGURE_ARGS+= --enable-freetype
+.else
+CONFIGURE_ARGS+= --disable-freetype
+.endif
+
+.if defined(WITH_XFT)
+LIB_DEPENDS+= Xft.2:${PORTSDIR}/x11-fonts/libXft
+CONFIGURE_ARGS+= --enable-xft2
+.else
+CONFIGURE_ARGS+= --disable-xft2
+.endif
+
+.if defined(WITH_GIF)
+LIB_DEPENDS+= ungif.5:${PORTSDIR}/graphics/libungif
+CONFIGURE_ARGS+= --enable-gif
+.else
+CONFIGURE_ARGS+= --disable-gif
+.endif
+
+.if defined(WITH_IMLIB)
+LIB_DEPENDS+= Imlib.5:${PORTSDIR}/graphics/imlib
+CONFIGURE_ARGS+= --enable-imlib
+.else
+CONFIGURE_ARGS+= --disable-imlib
+.endif
+
+.if defined(WITH_JAPANESE)
+LIB_DEPENDS+= VFlib2.24:${PORTSDIR}/japanese/vflib
+CONFIGURE_ARGS+= --enable-vflib \
+ --with-vfontcap=`${LS} -1 ${LOCALBASE}/share/VFlib/*/vfontcap | tail -1` \
+ --enable-freetype-charset16
+.else
+CONFIGURE_ARGS+= --disable-vflib
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|varargs.h|stdarg.h|' \
${WRKSRC}/image/rlelib.c