aboutsummaryrefslogtreecommitdiffstats
path: root/misc/thefuck/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/thefuck/Makefile')
-rw-r--r--misc/thefuck/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/misc/thefuck/Makefile b/misc/thefuck/Makefile
new file mode 100644
index 000000000000..09a81828f99f
--- /dev/null
+++ b/misc/thefuck/Makefile
@@ -0,0 +1,25 @@
+# Created by: Guangyuan Yang <ygy@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= thefuck
+DISTVERSION= 3.25
+CATEGORIES= misc python
+MASTER_SITES= CHEESESHOP
+
+MAINTAINER= ygy@FreeBSD.org
+COMMENT= App that corrects your previous console command
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}colorama>0:devel/py-colorama@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}decorator>0:devel/py-decorator@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}psutil>0:sysutils/py-psutil@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyte>0:devel/py-pyte@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR}
+
+USES= python:3.4+
+USE_PYTHON= autoplist distutils noflavors
+NO_ARCH= yes
+
+.include <bsd.port.mk>