aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
Diffstat (limited to 'misc')
-rw-r--r--misc/amanda-perl-wrapper/Makefile3
-rw-r--r--misc/amanda25-server/Makefile5
-rw-r--r--misc/amanda26-server/Makefile4
-rw-r--r--misc/amanda32-server/Makefile4
-rw-r--r--misc/hello/Makefile4
-rw-r--r--misc/mc/Makefile4
-rw-r--r--misc/ossp-uuid/Makefile2
7 files changed, 10 insertions, 16 deletions
diff --git a/misc/amanda-perl-wrapper/Makefile b/misc/amanda-perl-wrapper/Makefile
index e554fe671034..15f571ebffce 100644
--- a/misc/amanda-perl-wrapper/Makefile
+++ b/misc/amanda-perl-wrapper/Makefile
@@ -14,7 +14,8 @@ DISTFILES= # empty
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Perl wrapper to use with Amanda (with libthr.so.* linked)
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
SUB_FILES= perl-amanda.c
SUB_LIST= PREFIX=${LOCALBASE}
PLIST_FILES= bin/perl-amanda
diff --git a/misc/amanda25-server/Makefile b/misc/amanda25-server/Makefile
index db833ab4d567..787638d987c3 100644
--- a/misc/amanda25-server/Makefile
+++ b/misc/amanda25-server/Makefile
@@ -17,7 +17,7 @@ SLAVEDIRS= misc/amanda25-client
LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
USE_AUTOTOOLS= autoconf
-USE_GMAKE= yes
+USES= gmake
USE_OPENSSL= yes
PATCH_STRIP=
CONFIGURE_ARGS= --libexecdir=${PREFIX}/libexec/amanda \
@@ -26,7 +26,6 @@ CONFIGURE_ARGS= --libexecdir=${PREFIX}/libexec/amanda \
--disable-libtool --prefix=${PREFIX} \
--with-user=${AMANDA_USER} --with-group=${AMANDA_GROUP}
USE_LDCONFIG= yes
-WANT_PERL= yes
SAMBA_PORT?= net/samba36
@@ -119,7 +118,7 @@ post-patch:
${WRKSRC}/server-src/amcrypt-ossl.sh.in \
${WRKSRC}/server-src/amcrypt-ossl-asym.sh.in
-USE_PERL5= yes
+USES+= perl5
BUILD_DEPENDS+= ${LOCALBASE}/sbin/amrecover:${PORTSDIR}/misc/amanda25-client
RUN_DEPENDS+= ${LOCALBASE}/sbin/amrecover:${PORTSDIR}/misc/amanda25-client
diff --git a/misc/amanda26-server/Makefile b/misc/amanda26-server/Makefile
index 3d2ab27c81d2..ac093d6ee97c 100644
--- a/misc/amanda26-server/Makefile
+++ b/misc/amanda26-server/Makefile
@@ -16,10 +16,9 @@ WRKSRC= ${WRKDIR}/amanda-${PORTVERSION}
SLAVEDIRS= misc/amanda26-client
NO_LATEST_LINK= yes
-USES= pkgconfig
+USES= gmake perl5 pkgconfig
GNU_CONFIGURE= yes
USE_GNOME= glib20
-USE_GMAKE= yes
USE_OPENSSL= yes
PATCH_STRIP=
CONFIGURE_ARGS= --libexecdir=${PREFIX}/libexec/amanda \
@@ -33,7 +32,6 @@ CONFIGURE_ARGS= --libexecdir=${PREFIX}/libexec/amanda \
--with-ssh-security
USE_LDCONFIG= yes
-USE_PERL5= yes
OPTIONS_DEFINE= GNUTAR
GNUTAR_DESC= use GNU tar
diff --git a/misc/amanda32-server/Makefile b/misc/amanda32-server/Makefile
index c03157644ec6..fe27fdf61be6 100644
--- a/misc/amanda32-server/Makefile
+++ b/misc/amanda32-server/Makefile
@@ -20,12 +20,10 @@ SLAVEDIRS= misc/amanda32-client
NO_LATEST_LINK= yes
GNU_CONFIGURE= yes
-USES= pkgconfig
+USES= gmake perl5 pkgconfig
USE_GNOME= glib20
-USE_GMAKE= yes
USE_OPENSSL= yes
USE_LDCONFIG= yes
-USE_PERL5= yes
CONFIGURE_ARGS= --libexecdir=${PREFIX}/libexec/amanda \
--without-amlibexecdir \
--with-amandahosts --with-fqdn \
diff --git a/misc/hello/Makefile b/misc/hello/Makefile
index 4be4dae1e3ce..6a69331e19d8 100644
--- a/misc/hello/Makefile
+++ b/misc/hello/Makefile
@@ -10,9 +10,9 @@ MASTER_SITE_SUBDIR= hello
MAINTAINER= dhn@FreeBSD.org
COMMENT= A utility for saying hello to the world and reading email
-USE_PERL5_BUILD= YES
+USES= charsetfix perl5
+USE_PERL5= build
GNU_CONFIGURE= YES
-USES= charsetfix
MAN1= hello.1
INFO= hello
diff --git a/misc/mc/Makefile b/misc/mc/Makefile
index eadaef0535a1..413440c481a2 100644
--- a/misc/mc/Makefile
+++ b/misc/mc/Makefile
@@ -16,10 +16,8 @@ LIB_DEPENDS= ssh2:${PORTSDIR}/security/libssh2
CONFLICTS= mc-light-4*
-USES= pkgconfig
-USE_GMAKE= yes
+USES= gmake perl5 pkgconfig
USE_GNOME= glib20
-USE_PERL5= yes
USE_XZ= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= ZIP=${UNZIP_CMD} UNZIP=${UNZIP_CMD}
diff --git a/misc/ossp-uuid/Makefile b/misc/ossp-uuid/Makefile
index 2ba193169aa1..bdfcf21fc27b 100644
--- a/misc/ossp-uuid/Makefile
+++ b/misc/ossp-uuid/Makefile
@@ -27,7 +27,7 @@ MAN1= uuid-config.1 uuid.1
MAN3= uuid.3 uuid++.3
.if defined(WITH_PERL)
-USE_PERL5= yes
+USES+= perl5
CONFIGURE_ENV+= PERL=${PERL5}
CONFIGURE_ARGS+= --with-perl
PLIST_SUB+= WITH_PERL=''