aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/dvdrip
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/dvdrip')
-rw-r--r--multimedia/dvdrip/Makefile2
-rw-r--r--multimedia/dvdrip/files/patch-lib::Video::DVDRip::Cluster::Title.pm28
-rw-r--r--multimedia/dvdrip/files/patch-lib::Video::DVDRip::Subtitle.pm11
-rw-r--r--multimedia/dvdrip/files/patch-lib::Video::DVDRip::Title.pm33
4 files changed, 73 insertions, 1 deletions
diff --git a/multimedia/dvdrip/Makefile b/multimedia/dvdrip/Makefile
index 39391cb77958..1e6544ca694a 100644
--- a/multimedia/dvdrip/Makefile
+++ b/multimedia/dvdrip/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= dvdrip
-PORTREVISION= 1
+PORTREVISION= 2
PORTVERSION= 0.50.18
CATEGORIES= multimedia
MASTER_SITES= http://www.exit1.org/dvdrip/dist/
diff --git a/multimedia/dvdrip/files/patch-lib::Video::DVDRip::Cluster::Title.pm b/multimedia/dvdrip/files/patch-lib::Video::DVDRip::Cluster::Title.pm
new file mode 100644
index 000000000000..17292ec05a88
--- /dev/null
+++ b/multimedia/dvdrip/files/patch-lib::Video::DVDRip::Cluster::Title.pm
@@ -0,0 +1,28 @@
+--- lib/Video/DVDRip/Cluster/Title.pm.orig Sat Apr 10 11:18:03 2004
++++ lib/Video/DVDRip/Cluster/Title.pm Sun Jan 9 17:41:11 2005
+@@ -276,10 +276,10 @@
+ } else {
+ $command .=
+ "dr_exec avimerge".
+- " -i $avi_file".
+ " -p $audio_file".
+ " -a $target_nr".
+- " -o $avi_file.merged &&".
++ " -o $avi_file.merged ".
++ " -i $avi_file &&".
+ " mv $avi_file.merged $target_file &&".
+ " rm $audio_file &&".
+ " echo DVDRIP_SUCCESS";
+@@ -312,10 +312,9 @@
+
+ my $command =
+ "mkdir -m 0775 -p '$audio_video_psu_dir' && ".
+- "${nice}dr_exec avimerge -i $avi_chunks_dir/*".
+- " -o $audio_video_psu_file ";
+-
++ "${nice}dr_exec avimerge -o $audio_video_psu_file";
+ $command .= " -p $audio_psu_file " if not $self->is_ogg;
++ $command .= " -i $avi_chunks_dir/*";
+
+ $command .= " && rm $avi_chunks_dir/*"
+ if $self->with_cleanup;
diff --git a/multimedia/dvdrip/files/patch-lib::Video::DVDRip::Subtitle.pm b/multimedia/dvdrip/files/patch-lib::Video::DVDRip::Subtitle.pm
new file mode 100644
index 000000000000..88b16e74d050
--- /dev/null
+++ b/multimedia/dvdrip/files/patch-lib::Video::DVDRip::Subtitle.pm
@@ -0,0 +1,11 @@
+--- lib/Video/DVDRip/Subtitle.pm.orig Wed Dec 29 20:15:32 2004
++++ lib/Video/DVDRip/Subtitle.pm Wed Dec 29 20:16:34 2004
+@@ -193,7 +193,7 @@
+ my %par = @_;
+ my ($filename, $time) = @par{'filename','time'};
+
+- my $catch = qx[identify -ping $filename 2>&1];
++ my $catch = qx[identify $filename 2>&1];
+ my ($width, $height);
+ ($width, $height) = ( $catch =~ /(\d+)x(\d+)/ );
+
diff --git a/multimedia/dvdrip/files/patch-lib::Video::DVDRip::Title.pm b/multimedia/dvdrip/files/patch-lib::Video::DVDRip::Title.pm
new file mode 100644
index 000000000000..b225ecdf31b2
--- /dev/null
+++ b/multimedia/dvdrip/files/patch-lib::Video::DVDRip::Title.pm
@@ -0,0 +1,33 @@
+--- lib/Video/DVDRip/Title.pm.orig Wed Dec 29 20:15:48 2004
++++ lib/Video/DVDRip/Title.pm Wed Dec 29 20:16:44 2004
+@@ -2152,10 +2152,10 @@
+
+ $command .=
+ "dr_exec avimerge".
+- " -i $avi_file".
+ " -p $audio_file".
+ " -a $target_nr".
+- " -o $avi_file.merged &&".
++ " -o $avi_file.merged".
++ " -i $avi_file &&".
+ " mv $avi_file.merged $avi_file &&".
+ " rm $audio_file &&".
+ " echo DVDRIP_SUCCESS";
+@@ -2540,7 +2540,7 @@
+ my $target_file = $self->preview_filename( type => $type );
+
+ my $catch = $self->system (
+- command => "identify -ping $source_file"
++ command => "identify $source_file"
+ );
+ my ($width, $height);
+ ($width, $height) = ( $catch =~ /(\d+)x(\d+)/ );
+@@ -2598,7 +2598,7 @@
+ }
+
+ my $catch = $self->system (
+- command => "identify -ping $source_file"
++ command => "identify $source_file"
+ );
+ my ($width, $height);
+ ($width, $height) = ( $catch =~ /(\d+)x(\d+)/ );