aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/libvpx/files
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/libvpx/files')
-rw-r--r--multimedia/libvpx/files/patch-build_make_Makefile16
-rw-r--r--multimedia/libvpx/files/patch-build_make_rtcd.sh9
-rw-r--r--multimedia/libvpx/files/patch-libs.mk13
3 files changed, 27 insertions, 11 deletions
diff --git a/multimedia/libvpx/files/patch-build_make_Makefile b/multimedia/libvpx/files/patch-build_make_Makefile
new file mode 100644
index 000000000000..68609ffff779
--- /dev/null
+++ b/multimedia/libvpx/files/patch-build_make_Makefile
@@ -0,0 +1,16 @@
+
+$FreeBSD$
+
+--- build/make/Makefile.orig
++++ build/make/Makefile
+@@ -230,8 +230,8 @@
+ define install_map_template
+ $(DIST_DIR)/$(1): $(2)
+ $(if $(quiet),@echo " [INSTALL] $$@")
+- $(qexec)mkdir -p $$(dir $$@)
+- $(qexec)cp -p $$< $$@
++ $(qexec)install -d %%DESTDIR%%$$(dir $$@)
++ $(qexec)install -p $$< %%DESTDIR%%$$(dir $$@)
+ endef
+
+ define archive_template
diff --git a/multimedia/libvpx/files/patch-build_make_rtcd.sh b/multimedia/libvpx/files/patch-build_make_rtcd.sh
deleted file mode 100644
index 47102f6f4583..000000000000
--- a/multimedia/libvpx/files/patch-build_make_rtcd.sh
+++ /dev/null
@@ -1,9 +0,0 @@
---- build/make/rtcd.sh.orig 2012-06-24 13:12:00.000000000 +0200
-+++ build/make/rtcd.sh 2012-06-24 13:13:01.000000000 +0200
-@@ -1,5 +1,6 @@
- #!/bin/sh
- self=$0
-+LANG=C
-
- usage() {
- cat <<EOF >&2
diff --git a/multimedia/libvpx/files/patch-libs.mk b/multimedia/libvpx/files/patch-libs.mk
index 7249b76bce53..a6cfaf19facd 100644
--- a/multimedia/libvpx/files/patch-libs.mk
+++ b/multimedia/libvpx/files/patch-libs.mk
@@ -3,9 +3,18 @@ $FreeBSD$
--- libs.mk.orig
+++ libs.mk
-@@ -242,8 +242,8 @@
- $(qexec)echo 'Conflicts:' >> $@
+@@ -209,7 +209,7 @@
+ $(addprefix $(BUILD_PFX),$(notdir $(LIBVPX_SO_SYMLINKS))),\
+ $(BUILD_PFX)$(LIBVPX_SO)))
+ $(eval $(call libvpx_symlink_template,\
+- $(addprefix $(DIST_DIR)/,$(LIBVPX_SO_SYMLINKS)),\
++ $(addprefix $(DESTDIR)/$(DIST_DIR)/,$(LIBVPX_SO_SYMLINKS)),\
+ $(DIST_DIR)/$(LIBSUBDIR)/$(LIBVPX_SO)))
+
+ INSTALL-LIBS-$(CONFIG_SHARED) += $(LIBVPX_SO_SYMLINKS)
+@@ -232,8 +232,8 @@
$(qexec)echo 'Libs: -L$${libdir} -lvpx' >> $@
+ $(qexec)echo 'Libs.private: -lm -pthread' >> $@
$(qexec)echo 'Cflags: -I$${includedir}' >> $@
-INSTALL-LIBS-yes += $(LIBSUBDIR)/pkgconfig/vpx.pc
-INSTALL_MAPS += $(LIBSUBDIR)/pkgconfig/%.pc %.pc