aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/mpegedit/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/mpegedit/Makefile')
-rw-r--r--multimedia/mpegedit/Makefile20
1 files changed, 15 insertions, 5 deletions
diff --git a/multimedia/mpegedit/Makefile b/multimedia/mpegedit/Makefile
index 1449155ff478..26dba411b0f9 100644
--- a/multimedia/mpegedit/Makefile
+++ b/multimedia/mpegedit/Makefile
@@ -1,6 +1,6 @@
-# New ports collection makefile for: mpegedit
-# Date created: Thu Aug 1 10:50:57 CDT 1996
-# Whom: erich@FreeBSD.org
+# New ports collection makefile for: mpegedit
+# Date created: Thu Aug 1 10:50:57 CDT 1996
+# Whom: erich@FreeBSD.org
#
# $FreeBSD$
#
@@ -13,9 +13,19 @@ DISTNAME= ${PORTNAME}_v${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-BUILD_DEPENDS= ${LOCALBASE}/include/pbmplus.h:${PORTSDIR}/graphics/netpbm
+LIB_DEPENDS= pnm.1:${PORTSDIR}/graphics/netpbm
USE_X_PREFIX= yes
-USE_GMAKE= yes
+
+post-extract:
+ @find ${WRKSRC} -name '.depend' | xargs ${RM} -f
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/mpeg_edit ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/mpeg_edit
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/mpeg_edit
+ ${INSTALL_DATA} ${WRKSRC}/manual.ps ${PREFIX}/share/doc/mpeg_edit
+.endif
.include <bsd.port.mk>