aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/transcode
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/transcode')
-rw-r--r--multimedia/transcode/Makefile2
-rw-r--r--multimedia/transcode/files/patch-configure55
2 files changed, 1 insertions, 56 deletions
diff --git a/multimedia/transcode/Makefile b/multimedia/transcode/Makefile
index 36383d289d0e..56a162d06278 100644
--- a/multimedia/transcode/Makefile
+++ b/multimedia/transcode/Makefile
@@ -7,7 +7,7 @@
PORTNAME= transcode
PORTVERSION= 1.0.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= multimedia
MASTER_SITES= http://dl.fkb.wormulon.net/transcode/ \
http://dl.kel.wormulon.net/transcode/ \
diff --git a/multimedia/transcode/files/patch-configure b/multimedia/transcode/files/patch-configure
index 59d32c00fcdd..078c40269e72 100644
--- a/multimedia/transcode/files/patch-configure
+++ b/multimedia/transcode/files/patch-configure
@@ -35,61 +35,6 @@
else
tc_pkg_err="yes"
-@@ -40561,14 +40561,14 @@
- echo "${ECHO_T}$pkg_config_sdl" >&6
-
-
-- if test x"sdl-config" != x"no" ; then
-+ if test x"sdl11-config" != x"no" ; then
- if test x"$w_sdl_p" != x"" ; then
-- if test -x $w_sdl_p/bin/sdl-config ; then
-- sdl_config="$w_sdl_p/bin/sdl-config"
-+ if test -x $w_sdl_p/bin/sdl11-config ; then
-+ sdl_config="$w_sdl_p/bin/sdl11-config"
- fi
- fi
-- # Extract the first word of "sdl-config", so it can be a program name with args.
--set dummy sdl-config; ac_word=$2
-+ # Extract the first word of "sdl11-config", so it can be a program name with args.
-+set dummy sdl11-config; ac_word=$2
- echo "$as_me:$LINENO: checking for $ac_word" >&5
- echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6
- if test "${ac_cv_path_sdl_config+set}" = set; then
-@@ -40856,7 +40856,7 @@
- for l in $sdl_ll ; do
- case $l in
- -L*) lpaths="$lpaths $l" ;;
-- -l*) test x"$l" != x"-lSDL" && xlibs="$xlibs $l" ;;
-+ -l*) test x"$l" != x"-lSDL-1.1" && xlibs="$xlibs $l" ;;
- *) xlf="$xlf $l" ;;
- esac
- done
-@@ -40872,13 +40872,13 @@
- if test x"SDL" != x"none" ; then
- save_LDFLAGS="$LDFLAGS"
- LDFLAGS="$LDFLAGS $sdl_ll"
-- echo "$as_me:$LINENO: checking for SDL_Init in -lSDL" >&5
--echo $ECHO_N "checking for SDL_Init in -lSDL... $ECHO_C" >&6
-+ echo "$as_me:$LINENO: checking for SDL_Init in -lSDL-1.1" >&5
-+echo $ECHO_N "checking for SDL_Init in -lSDL-1.1... $ECHO_C" >&6
- if test "${ac_cv_lib_SDL_SDL_Init+set}" = set; then
- echo $ECHO_N "(cached) $ECHO_C" >&6
- else
- ac_check_lib_save_LIBS=$LIBS
--LIBS="-lSDL $SDL_EXTRA_LIBS $LIBS"
-+LIBS="-lSDL-1.1 $SDL_EXTRA_LIBS $LIBS"
- cat >conftest.$ac_ext <<_ACEOF
- /* confdefs.h. */
- _ACEOF
-@@ -40937,7 +40937,7 @@
- echo "$as_me:$LINENO: result: $ac_cv_lib_SDL_SDL_Init" >&5
- echo "${ECHO_T}$ac_cv_lib_SDL_SDL_Init" >&6
- if test $ac_cv_lib_SDL_SDL_Init = yes; then
-- SDL_LIBS="$sdl_ll -lSDL $SDL_EXTRA_LIBS"
-+ SDL_LIBS="$sdl_ll -lSDL-1.1 $SDL_EXTRA_LIBS"
- else
-
- tc_pkg_err="yes"
@@ -41429,7 +41429,7 @@
for l in $gtk_ll ; do
case $l in