aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/xfce4-parole/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/xfce4-parole/Makefile')
-rw-r--r--multimedia/xfce4-parole/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/multimedia/xfce4-parole/Makefile b/multimedia/xfce4-parole/Makefile
new file mode 100644
index 000000000000..4665027f80b4
--- /dev/null
+++ b/multimedia/xfce4-parole/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: Xfce4-parole
+# Date created: 26 December 2009
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xfce4-parole
+PORTVERSION= 0.1.99
+CATEGORIES= multimedia xfce
+MASTER_SITES= http://archive.xfce.org/src/apps/parole/0.1/
+DISTNAME= parole-${PORTVERSION}
+DIST_SUBDIR= xfce4
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= Lightweight media player for Xfce4 based on the gstreamer engine
+
+LIB_DEPENDS= tag:${PORTSDIR}/audio/taglib
+
+GNU_CONFIGURE= yes
+INSTALLS_ICONS= yes
+USE_BZIP2= yes
+USE_GSTREAMER= ffmpeg good theora xvid mp3 faad ogg dvd x264
+USE_GMAKE= yes
+CONFIGURE_ARGS= --disable-power-manager-plugin --disable-browser-plugin
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+USE_GNOME= gnomehack intltool intlhack pkgconfig
+USE_XFCE= configenv libexo libgui libutil panel
+USE_XORG= x11 sm
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.mk>