aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/py-periscope/Makefile16
-rw-r--r--multimedia/py-periscope/pkg-plist2
-rw-r--r--multimedia/quodlibet/Makefile54
3 files changed, 29 insertions, 43 deletions
diff --git a/multimedia/py-periscope/Makefile b/multimedia/py-periscope/Makefile
index 20851c4a331c..3f05f36e4427 100644
--- a/multimedia/py-periscope/Makefile
+++ b/multimedia/py-periscope/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: periscope
-# Date created: Sun Jul 24 20:23:58 UTC 2011
-# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
-#
+# Created by: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
# $FreeBSD$
PORTNAME= periscope
@@ -27,8 +24,12 @@ USE_GNOME= desktopfileutils
USE_PYTHON= 2.6+
USE_PYDISTUTILS= easy_install
NO_WRKSUBDIR= yes
+USES= desktop-file-utils
-OPTIONS= UNRAR "Enable support for rar (.rar) compressed subtitles" on
+OPTIONS_DEFINE= UNRAR
+UNRAR_DESC= rar support (.rar) for compressed subtitles
+
+OPTIONS_DEFAULT= UNRAR
PLIST_SUB= DESKTOPDIR=${DESKTOPDIR_WITHOUT_PREFIX:Q}
@@ -38,12 +39,11 @@ post-install:
@${MKDIR} ${DESKTOPDIR}
@${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/periscope.desktop \
${DESKTOPDIR}
- @-${LOCALBASE}/bin/update-desktop-database
+.include <bsd.port.options.mk>
.include <bsd.port.pre.mk>
-# unrar (.rar) support
-.if !defined(WITHOUT_UNRAR)
+.if ${PORT_OPTIONS:MUNRAR}
RUN_DEPENDS+= unrar:${PORTSDIR}/archivers/unrar
.endif
diff --git a/multimedia/py-periscope/pkg-plist b/multimedia/py-periscope/pkg-plist
index 700a17b9de27..18979ee9c065 100644
--- a/multimedia/py-periscope/pkg-plist
+++ b/multimedia/py-periscope/pkg-plist
@@ -1,5 +1,3 @@
bin/periscope
%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
%%DESKTOPDIR%%/periscope.desktop
-@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
-@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
diff --git a/multimedia/quodlibet/Makefile b/multimedia/quodlibet/Makefile
index 7cb87affd4f4..fb1a54cfe9d0 100644
--- a/multimedia/quodlibet/Makefile
+++ b/multimedia/quodlibet/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: quodlibet
-# Date created: 19 December 2005
-# Whom: Byung-Hee HWANG <bh@izb.knu.ac.kr>
-#
+# Created by: Byung-Hee HWANG <bh@izb.knu.ac.kr>
# $FreeBSD$
-#
PORTNAME= quodlibet
PORTVERSION= 2.2
@@ -26,76 +22,68 @@ USE_GSTREAMER= gconf good python
MAN1= exfalso.1 quodlibet.1
-OPTIONS= FLAC "Flac audio support" on
-OPTIONS+= MP3 "MP3 audio support" on
-OPTIONS+= MPEG4IP "AAC/mp4 support with MPEG4IP" on
-OPTIONS+= MUSEPACK "Musepack (MPC, musicpd, libmpcdec) support" on
-OPTIONS+= OGG "OGG multimedia container support" on
-OPTIONS+= SPC "SPC (SNES ROM audio) support" on
-OPTIONS+= SPEEX "OGG/Speex audio support" on
-OPTIONS+= VORBIS "OGG/Vorbis audio support" on
-OPTIONS+= WAVPACK "Wavpack support" on
-OPTIONS+= DBUS "Enable dbus (iPod, storage) support" on
-OPTIONS+= REMOTE "Enable remote playback" on
-OPTIONS+= EXTENSIONS "Enable extensions" off
+OPTIONS_DEFINE= FLAC MP3 AAC MUSEPACK OGG SPC SPEEX VORBIS WAVPACK DBUS REMOTE EXTENSIONS
+SPC_DESC= SPC (SNES ROM audio) support
+SPEEX_DESC= OGG/Speex audio support
+REMOTE_DESC= Enable remote playback
+EXTENSIONS_DESC= Enable extensions
+OPTIONS_DEFAULT= FLAC MP3 AAC MUSEPACK OGG SPC SPEEX VORBIS WAVPACK DBUS REMOTE
+
+.include <bsd.port.options.mk>
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_OGG)
+.if ${PORT_OPTIONS:MOGG}
USE_GSTREAMER+= ogg
.endif
-.if !defined(WITHOUT_VORBIS)
+.if ${PORT_OPTIONS:MVORBIS}
USE_GSTREAMER+= vorbis
.endif
-.if !defined(WITHOUT_SPC)
+.if ${PORT_OPTIONS:MSPC}
USE_GSTREAMER+= spc
.endif
-.if !defined(WITHOUT_SPEEX)
+.if ${PORT_OPTIONS:MSPEEX}
USE_GSTREAMER+= speex
.endif
-.if !defined(WITHOUT_MP3)
+.if ${PORT_OPTIONS:MMP3}
USE_GSTREAMER+= mp3
.endif
-.if !defined(WITHOUT_FLAC)
+.if ${PORT_OPTIONS:MFLAC}
USE_GSTREAMER+= flac
.endif
-.if !defined(WITHOUT_MUSEPACK) || !defined(WITHOUT_WAVPACK) \
- || !defined(WITHOUT_MPEG4IP)
-.endif
-
-.if !defined(WITHOUT_MUSEPACK)
+.if ${PORT_OPTIONS:MMUSEPACK}
LIB_DEPENDS+= mpcdec.7:${PORTSDIR}/audio/musepack
USE_GSTREAMER+= musepack
.endif
-.if !defined(WITHOUT_WAVPACK)
+.if ${PORT_OPTIONS:MWAVPACK}
LIB_DEPENDS+= wavpack.2:${PORTSDIR}/audio/wavpack
USE_GSTREAMER+= wavpack
.endif
-.if !defined(WITHOUT_MPEG4IP)
+.if ${PORT_OPTIONS:MAAC}
LIB_DEPENDS+= mp4v2.10:${PORTSDIR}/multimedia/mp4v2
USE_GSTREAMER+= faad
.endif
-.if !defined(WITHOUT_DBUS)
+.if ${PORT_OPTIONS:MDBUS}
BUILD_DEPENDS+= ${PYTHON_SITELIBDIR}/dbus/__init__.py:${PORTSDIR}/devel/py-dbus
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/dbus/__init__.py:${PORTSDIR}/devel/py-dbus
.endif
-.if !defined(WITHOUT_REMOTE)
+.if ${PORT_OPTIONS:MREMOTE}
BUILD_DEPENDS+= ${PYTHON_SITELIBDIR}/feedparser.py:${PORTSDIR}/textproc/py-feedparser
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/feedparser.py:${PORTSDIR}/textproc/py-feedparser
USE_GSTREAMER+= gnomevfs
.endif
-.if defined(WITH_EXTENSIONS)
+.if ${PORT_OPTIONS:MEXTENSIONS}
USE_GNOME+= pygnomeextras
PLIST_SUB+= EXTENSIONS=""
.else