aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/bmpx/Makefile56
-rw-r--r--multimedia/bmpx/distinfo6
-rw-r--r--multimedia/bmpx/files/patch-Makefile.in11
-rw-r--r--multimedia/bmpx/files/patch-libhrel-Makefile.in21
-rw-r--r--multimedia/bmpx/files/patch-src-embedded--images-Makefile.in17
-rw-r--r--multimedia/bmpx/pkg-descr12
-rw-r--r--multimedia/bmpx/pkg-plist128
7 files changed, 132 insertions, 119 deletions
diff --git a/multimedia/bmpx/Makefile b/multimedia/bmpx/Makefile
index b1d3109c66f6..6eb88ff437db 100644
--- a/multimedia/bmpx/Makefile
+++ b/multimedia/bmpx/Makefile
@@ -6,40 +6,70 @@
#
PORTNAME= bmpx
-PORTVERSION= 0.12.2
+PORTVERSION= 0.12.9
CATEGORIES= multimedia
-MASTER_SITES= http://download.berlios.de/bmpx/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= beepmp
MAINTAINER= novel@FreeBSD.org
COMMENT= Audio player
LIB_DEPENDS= tag.5:${PORTSDIR}/audio/taglib \
- fam.0:${PORTSDIR}/devel/fam \
- xine.14:${PORTSDIR}/multimedia/libxine
+ xine.14:${PORTSDIR}/multimedia/libxine \
+ curl.3:${PORTSDIR}/ftp/curl
+USE_AUTOTOOLS= libtool:15
USE_BZIP2= yes
+USE_FAM= yes
+USE_GCC= 3.4+
USE_GMAKE= yes
-USE_GNOME= gtk20 libglade2
-USE_AUTOTOOLS= libtool:15
+USE_GNOME= gtk20 libglade2 desktopfileutils
+LIBTOOLFILES= configure libhrel/configure libskinned/configure
USE_X_PREFIX= yes
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --enable-xine --disable-gst
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include -D__BSD_VISIBLE ${PTHREAD_CFLAGS}" \
+ LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}"
MAN1= bmpx.1
-post-extract:
- @${REINPLACE_CMD} -e 's|-Wall -pedantic -std=c99||' \
- ${WRKSRC}/configure
-
.if defined(WITHOUT_DBUS)
CONFIGURE_ARGS+= --disable-dbus
.else
LIB_DEPENDS+= dbus-1.1:${PORTSDIR}/devel/dbus
.endif
-.include <bsd.port.mk>
+.if defined(WITHOUT_PERL)
+CONFIGURE_ARGS+= --disable-perl
+.else
+USE_PERL5_BUILD= yes
+.endif
+
+.if defined(WITHOUT_PYTHON)
+CONFIGURE_ARGS+= --disable-python
+PLIST_SUB+= PYTHON="@comment "
+.else
+USE_PYTHON= yes
+USE_GNOME+= pygtk2
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/dbus.pth:${PORTSDIR}/devel/py-dbus
+PLIST_SUB+= PYTHON=""
+.endif
+
+.if defined(WITHOUT_STARTUP_NOTIFICATION)
+CONFIGURE_ARGS+= --disable-sn
+.else
+LIB_DEPENDS+= startup-notification-1.0:${PORTSDIR}/x11/startup-notification
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+post-patch:
+ @${REINPLACE_CMD} -e 's|<stdint.h>|<inttypes.h>|' \
+ ${WRKSRC}/src/metadata.c
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/multimedia/bmpx/distinfo b/multimedia/bmpx/distinfo
index d53fd6fe469d..d1aafad6b0ab 100644
--- a/multimedia/bmpx/distinfo
+++ b/multimedia/bmpx/distinfo
@@ -1,3 +1,3 @@
-MD5 (bmpx-0.12.2.tar.bz2) = 840bca5822c90b2812b0fdcf77cae10e
-SHA256 (bmpx-0.12.2.tar.bz2) = 067e292e1e6e77b25f2a860db681826ccd70504c63c968c69f3dace2ccfb8faa
-SIZE (bmpx-0.12.2.tar.bz2) = 1219915
+MD5 (bmpx-0.12.9.tar.bz2) = 4449eb429dc7bfb9c2ec3feb9e8c7e56
+SHA256 (bmpx-0.12.9.tar.bz2) = 12bd7377e1744cb95839e3fac38e119db6d9901ec465c4e0b2d794b0bbb47bb2
+SIZE (bmpx-0.12.9.tar.bz2) = 1619487
diff --git a/multimedia/bmpx/files/patch-Makefile.in b/multimedia/bmpx/files/patch-Makefile.in
deleted file mode 100644
index 19e685cab4da..000000000000
--- a/multimedia/bmpx/files/patch-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig Sun Nov 20 17:24:50 2005
-+++ Makefile.in Sun Nov 20 17:25:07 2005
-@@ -257,7 +257,7 @@
- libexecdir = @libexecdir@
- localedir = @localedir@
- localstatedir = @localstatedir@
--mandir = $(datadir)/man
-+mandir = $(prefix)/man
- mkdir_p = @mkdir_p@
- oldincludedir = @oldincludedir@
- prefix = @prefix@
diff --git a/multimedia/bmpx/files/patch-libhrel-Makefile.in b/multimedia/bmpx/files/patch-libhrel-Makefile.in
index 2350211db758..65a02316046f 100644
--- a/multimedia/bmpx/files/patch-libhrel-Makefile.in
+++ b/multimedia/bmpx/files/patch-libhrel-Makefile.in
@@ -1,11 +1,12 @@
---- libhrel/Makefile.in.orig Wed Nov 23 14:11:02 2005
-+++ libhrel/Makefile.in Wed Nov 23 14:12:47 2005
-@@ -192,7 +192,7 @@
- target_os = @target_os@
- target_vendor = @target_vendor@
- SUBDIRS = libhrel docs
--pkgconfigdir = ${libdir}/pkgconfig
+--- libhrel/Makefile.in.bak Wed Nov 23 01:43:28 2005
++++ libhrel/Makefile.in Thu Nov 24 22:45:37 2005
+@@ -186,8 +186,8 @@
+ mandir = @mandir@
+ mkdir_p = @mkdir_p@
+ oldincludedir = @oldincludedir@
+-pkgconfigdir = @pkgconfigdir@
+ prefix = @prefix@
+pkgconfigdir = ${prefix}/libdata/pkgconfig
- pkgconfig_DATA = hrel.pc
- DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc
- all: config.h
+ program_transform_name = @program_transform_name@
+ sbindir = @sbindir@
+ sharedstatedir = @sharedstatedir@
diff --git a/multimedia/bmpx/files/patch-src-embedded--images-Makefile.in b/multimedia/bmpx/files/patch-src-embedded--images-Makefile.in
deleted file mode 100644
index 3e0ee83507cc..000000000000
--- a/multimedia/bmpx/files/patch-src-embedded--images-Makefile.in
+++ /dev/null
@@ -1,17 +0,0 @@
---- src/embedded-images/Makefile.in.orig Sun Oct 30 13:45:16 2005
-+++ src/embedded-images/Makefile.in Sun Nov 20 16:09:11 2005
-@@ -456,10 +456,11 @@
- media-pixbufs.h: $(EXTRA_DIST)
- @echo "* Generating media icons"
- @gdk-pixbuf-csource --build-list \
-- `for x in $(basename $(notdir $(dist_noinst_DATA))); do \
-- echo "$${x/-/_}"; \
-- echo " $(srcdir)/$${x}.png";\
-+ `for x in $(dist_noinst_DATA); do \
-+ echo $${x}|sed -e s/-/_/| sed -e s/\.png//; \
-+ echo " $(srcdir)/$${x}";\
- done` > media-pixbufs.h
-+
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.
- .NOEXPORT:
diff --git a/multimedia/bmpx/pkg-descr b/multimedia/bmpx/pkg-descr
index 125bb222500f..448fd62ffe72 100644
--- a/multimedia/bmpx/pkg-descr
+++ b/multimedia/bmpx/pkg-descr
@@ -1,8 +1,8 @@
-BMPx is an audio player that can be either used with a built-in
+BMPx is an audio player that can be either used with a built-in
frontend which currently utilizes Winamp 2.x compatible skins, or
-as a daemon for other frontends to connect via a DBus
-interface. It can run under X11 with graphical GUIs, or without X
-under plain UNIX terminal as a daemon (in which case it
-requires a different frontend connecting to it via DBus).
+as a daemon for other frontends to connect via a DBus interface.
+It can run under X11 with graphical GUIs, or without X under
+plain UNIX terminal as a daemon (in which case it requires a
+different frontend connecting to it via DBus).
-WWW: http://bmpx.berlios.de/
+WWW: http://beep-media-player.org/
diff --git a/multimedia/bmpx/pkg-plist b/multimedia/bmpx/pkg-plist
index cb88bc8c2fa3..a9a99f770950 100644
--- a/multimedia/bmpx/pkg-plist
+++ b/multimedia/bmpx/pkg-plist
@@ -1,11 +1,13 @@
-@comment $FreeBSD$
-bin/bmp-dbus-introspect
-bin/bmp-dbus-query-lists
-bin/bmp-dbus-system-control
-bin/bmp-remote-pygtk
-bin/bmpty
+bin/bmpx-dbus-introspect
+bin/bmpx-dbus-query-lists
+bin/bmpx-dbus-system-control
bin/bmpx
+bin/bmpx-remote
+bin/hash_index
+bin/hash_table
bin/hrel-demo
+%%PYTHON%%bin/bmpx-client-pygtk
+%%PYTHON%%bin/bmpty
include/bmpx/dbus.h
include/bmpx/file_utils.h
include/bmpx/interfaces/plugin_interface_container.h
@@ -21,14 +23,25 @@ include/bmpx/sanity.h
include/bmpx/uri.h
include/bmpx/util.h
include/bmpx/vfs.h
-include/bmpx/xml.h
+include/libhrel/libhrel/attr_map.h
+include/libhrel/libhrel/avl_tree_index.h
+include/libhrel/libhrel/btree.h
+include/libhrel/libhrel/hash_index.h
+include/libhrel/libhrel/hash_table.h
+include/libhrel/libhrel/misc.h
include/libhrel/libhrel/relation.h
include/libhrel/libhrel/relation_base.h
+include/libhrel/libhrel/relation_project.h
include/libhrel/libhrel/relation_restrict.h
include/libhrel/libhrel/relation_sort.h
include/libhrel/libhrel/stack.h
include/libhrel/libhrel/tuple.h
include/libhrel/libhrel/types.h
+include/libskinned/libskinned/bmp_button.h
+include/libskinned/libskinned/bmp_button_toggle.h
+include/libskinned/libskinned/bmp_slider.h
+include/libskinned/libskinned/bmp_tooltips.h
+include/libskinned/libskinned/bmp_window.h
lib/bmpx/plugins/container/libcontainer_folder.a
lib/bmpx/plugins/container/libcontainer_folder.so
lib/bmpx/plugins/container/libcontainer_folder.so.0
@@ -56,22 +69,27 @@ lib/bmpx/plugins/transport/libtransport_file.so.0
lib/bmpx/plugins/transport/libtransport_http.a
lib/bmpx/plugins/transport/libtransport_http.so
lib/bmpx/plugins/transport/libtransport_http.so.0
-lib/libhrel.la
+lib/libhrel.a
lib/libhrel.so
lib/libhrel.so.1
lib/libskinned.a
+lib/libskinned.so.1
lib/libskinned.so
-lib/libskinned.so.0
+lib/libgoa.a
+lib/libxcs.a
+@comment %%PYTHON_XCHAT%%lib/xchat/plugins/bmpx-xchat.py
libdata/pkgconfig/hrel.pc
share/applications/bmpx.desktop
-share/bmp-remote/pygtk/bmp-remote-image.png
-share/bmp-remote/pygtk/bmp_remote.glade
+share/applications/bmpx_enqueue.desktop
+%%PYTHON%%share/bmpx-clients/pygtk/bmpx-client-image.png
+%%PYTHON%%share/bmpx-clients/pygtk/bmpx_client.glade
%%DATADIR%%/data/GPL.txt
+%%DATADIR%%/glade/bmpx-remote.glade
%%DATADIR%%/glade/dialog_add_files.glade
-%%DATADIR%%/glade/dialog_add_from_library.glade
%%DATADIR%%/glade/dialog_add_url.glade
%%DATADIR%%/glade/dialog_export_tracklist.glade
%%DATADIR%%/glade/dialog_file_info.glade
+%%DATADIR%%/glade/dialog_library.glade
%%DATADIR%%/glade/dialog_new_list_from_selection.glade
%%DATADIR%%/glade/dialog_preferences.glade
%%DATADIR%%/glade/dialog_rename_tracklist.glade
@@ -105,6 +123,11 @@ share/bmp-remote/pygtk/bmp_remote.glade
%%DATADIR%%/icons/themes/plastic/icon_playlist_32.png
%%DATADIR%%/icons/themes/plastic/icon_playlist_48.png
%%DATADIR%%/icons/themes/plastic/icon_playlist_64.png
+%%DATADIR%%/icons/themes/red/icon_library_128.png
+%%DATADIR%%/icons/themes/red/icon_library_16.png
+%%DATADIR%%/icons/themes/red/icon_library_32.png
+%%DATADIR%%/icons/themes/red/icon_library_48.png
+%%DATADIR%%/icons/themes/red/icon_library_64.png
%%DATADIR%%/icons/themes/red/icon_player_128.png
%%DATADIR%%/icons/themes/red/icon_player_16.png
%%DATADIR%%/icons/themes/red/icon_player_32.png
@@ -125,8 +148,7 @@ share/bmp-remote/pygtk/bmp_remote.glade
%%DATADIR%%/images/audio.png
%%DATADIR%%/images/eq.png
%%DATADIR%%/images/eq_ia.png
-%%DATADIR%%/images/library.png
-%%DATADIR%%/images/library_ia.png
+%%DATADIR%%/images/library-headerlogo.png
%%DATADIR%%/images/logo-experimental.png
%%DATADIR%%/images/mouse.png
%%DATADIR%%/images/mouse_ia.png
@@ -137,7 +159,10 @@ share/bmp-remote/pygtk/bmp_remote.glade
%%DATADIR%%/images/plugins.png
%%DATADIR%%/images/plugins_ia.png
%%DATADIR%%/images/preferences-logo.png
+%%DATADIR%%/images/shoutcast.png
+%%DATADIR%%/images/splash.png
%%DATADIR%%/images/wait.gif
+%%DATADIR%%/images/xiph.png
%%DATADIR%%/skins/default/README
%%DATADIR%%/skins/default/balance.bmp
%%DATADIR%%/skins/default/cbuttons.bmp
@@ -158,59 +183,44 @@ share/bmp-remote/pygtk/bmp_remote.glade
%%DATADIR%%/ui/main.ui
%%DATADIR%%/ui/playlist.ui
%%DATADIR%%/ui/trayicon.ui
-share/gtk-doc/html/libhrel/ch06.html
-share/gtk-doc/html/libhrel/fundamentals.html
-share/gtk-doc/html/libhrel/home.png
-share/gtk-doc/html/libhrel/index.html
-share/gtk-doc/html/libhrel/index.sgml
-share/gtk-doc/html/libhrel/left.png
-share/gtk-doc/html/libhrel/libhrel-BTree.html
-share/gtk-doc/html/libhrel/libhrel-Relation.html
-share/gtk-doc/html/libhrel/libhrel-Restricted-Relation.html
-share/gtk-doc/html/libhrel/libhrel-Sorted-Relation.html
-share/gtk-doc/html/libhrel/libhrel-Stack.html
-share/gtk-doc/html/libhrel/libhrel-Tuple.html
-share/gtk-doc/html/libhrel/libhrel-Type-system.html
-share/gtk-doc/html/libhrel/libhrel.devhelp
-share/gtk-doc/html/libhrel/overview.html
-share/gtk-doc/html/libhrel/relations.html
-share/gtk-doc/html/libhrel/right.png
-share/gtk-doc/html/libhrel/style.css
-share/gtk-doc/html/libhrel/tuple.html
-share/gtk-doc/html/libhrel/type-system.html
-share/gtk-doc/html/libhrel/up.png
share/icons/hicolor/48x48/apps/bmpx.png
share/locale/af/LC_MESSAGES/bmpx.mo
share/locale/bg/LC_MESSAGES/bmpx.mo
share/locale/de/LC_MESSAGES/bmpx.mo
share/locale/el/LC_MESSAGES/bmpx.mo
share/locale/fr/LC_MESSAGES/bmpx.mo
+share/locale/hu/LC_MESSAGES/bmpx.mo
share/locale/ja/LC_MESSAGES/bmpx.mo
-@dirrm include/bmpx/interfaces
-@dirrm include/bmpx
-@dirrm include/libhrel/libhrel
-@dirrm include/libhrel
-@dirrm lib/bmpx/plugins/container
-@dirrm lib/bmpx/plugins/flow
-@dirrm lib/bmpx/plugins/transport
-@dirrm lib/bmpx/plugins
-@dirrm lib/bmpx
-@dirrm share/bmp-remote/pygtk
-@dirrm share/bmp-remote
-@dirrm %%DATADIR%%/icons/themes/darksphere
-@dirrm %%DATADIR%%/icons/themes/display
-@dirrm %%DATADIR%%/icons/themes/plastic
+share/locale/lt/LC_MESSAGES/bmpx.mo
+share/locale/pl/LC_MESSAGES/bmpx.mo
+share/locale/ru/LC_MESSAGES/bmpx.mo
+@dirrm %%DATADIR%%/ui
+@dirrm %%DATADIR%%/skins/default
+@dirrm %%DATADIR%%/skins
+@dirrm %%DATADIR%%/images
+@dirrm %%DATADIR%%/icons/tray-icons
@dirrm %%DATADIR%%/icons/themes/red
+@dirrm %%DATADIR%%/icons/themes/plastic
+@dirrm %%DATADIR%%/icons/themes/display
+@dirrm %%DATADIR%%/icons/themes/darksphere
@dirrm %%DATADIR%%/icons/themes
-@dirrm %%DATADIR%%/icons/tray-icons
-@dirrm %%DATADIR%%/skins/default
-@dirrm %%DATADIR%%/data
-@dirrm %%DATADIR%%/glade
@dirrm %%DATADIR%%/icons
-@dirrm %%DATADIR%%/images
-@dirrm %%DATADIR%%/skins
-@dirrm %%DATADIR%%/ui
+@dirrm %%DATADIR%%/glade
+@dirrm %%DATADIR%%/data
@dirrm %%DATADIR%%
-@dirrm share/gtk-doc/html/libhrel
-@dirrm share/gtk-doc/html
-@dirrm share/gtk-doc
+@dirrm lib/bmpx/plugins/transport
+@dirrm lib/bmpx/plugins/flow
+@dirrm lib/bmpx/plugins/container
+@dirrm lib/bmpx/plugins
+@dirrm lib/bmpx
+@dirrm include/libskinned/libskinned
+@dirrm include/libskinned
+@dirrm include/libhrel/libhrel
+@dirrm include/libhrel
+@dirrm include/bmpx/interfaces
+@dirrm include/bmpx
+%%PYTHON%%@dirrm share/bmpx-clients/pygtk
+%%PYTHON%%@dirrm share/bmpx-clients
+@unexec rmdir %D/share/applications 2>/dev/null || true
+@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true