aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mjpegtools/Makefile28
-rw-r--r--multimedia/mjpegtools/files/patch-mplex__Makefile.in11
2 files changed, 21 insertions, 18 deletions
diff --git a/multimedia/mjpegtools/Makefile b/multimedia/mjpegtools/Makefile
index 6f72b3aac748..38280cdcd7e6 100644
--- a/multimedia/mjpegtools/Makefile
+++ b/multimedia/mjpegtools/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mjpegtools
PORTVERSION= 2.1.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= multimedia
MASTER_SITES= SF/${PORTNAME:S/tools//}/${PORTNAME}/${PORTVERSION}
@@ -18,21 +18,17 @@ LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg
CONFLICTS= mplex-[0-9]*
USES= gmake libtool pathfix pkgconfig
-PATHFIX_MAKEFILEIN= Makefile.am
-USE_AUTOTOOLS= libtoolize aclocal autoheader automake autoconf
-LIBTOOLIZE_ARGS=-i -c -f
-ACLOCAL_ARGS= --automake-acdir=${ACLOCAL_DIR} \
- -I ${LOCALBASE}/share/aclocal
-AUTOMAKE_ARGS= --add-missing --foreign
-CONFIGURE_ARGS= --without-dga --without-x
USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --without-dga --without-x
+CONFIGURE_TARGET= ${ARCH:S/amd64/x86_64/}-portbld-${OPSYS:tl}${OSREL}
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib
INFO= mjpeg-howto
-OPTIONS_DEFINE= DOCS DV GTK2 PNG QUICKTIME SDL SIMD
+OPTIONS_DEFINE= DOCS DV GTK2 PNG QUICKTIME SDL
OPTIONS_DEFAULT= GTK2 PNG SDL
OPTIONS_SUB= yes
@@ -46,12 +42,11 @@ QUICKTIME_LIB_DEPENDS= libquicktime.so:${PORTSDIR}/multimedia/libquicktime
QUICKTIME_CONFIGURE_WITH= libquicktime
SDL_USE= SDL=gfx,sdl
SDL_CONFIGURE_OFF= --without-libsdl --without-sdlgfx
-SIMD_CONFIGURE_ENABLE= simd-accel
.include <bsd.port.options.mk>
.if ${ARCH} == "i386"
-CFLAGS:= ${CFLAGS:N-O*:N-fno-strict*}
+USES+= compiler:c++11-lang
.endif
.if ${ARCH} == "powerpc" && ${OSVERSION} > 900000
@@ -59,12 +54,9 @@ BROKEN= Does not build on powerpc-9
.endif
post-patch:
- @${REINPLACE_CMD} -e \
- 's| \*-\*-linux\*)| *-*-*)| ; \
- /ARCHFLAGS=/s|^|#|g' ${WRKSRC}/configure.ac
-
-pre-configure:
- @${RM} -f ${WRKSRC}/missing
+ @${REINPLACE_CMD} \
+ -e 's| \*-\*-linux\*)| *-*-*)|' \
+ -e '/ARCHFLAGS=/d' ${WRKSRC}/configure
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/multimedia/mjpegtools/files/patch-mplex__Makefile.in b/multimedia/mjpegtools/files/patch-mplex__Makefile.in
new file mode 100644
index 000000000000..264d24adeb29
--- /dev/null
+++ b/multimedia/mjpegtools/files/patch-mplex__Makefile.in
@@ -0,0 +1,11 @@
+--- mplex/Makefile.in.orig
++++ mplex/Makefile.in
+@@ -360,7 +360,7 @@
+ libmplex2_la_CXXFLAGS =
+ mplex_SOURCES = main.cpp
+ mplex_DEPENDENCIES = libmplex2.la
+-mplex_LDADD = libmplex2.la @LIBGETOPT_LIB@ $(LIBM_LIBS)
++mplex_LDADD = libmplex2.la $(top_builddir)/utils/libmjpegutils.la @LIBGETOPT_LIB@ $(LIBM_LIBS)
+ all: all-am
+
+ .SUFFIXES: