aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/mp3cd/Makefile25
-rw-r--r--multimedia/mp3cd/distinfo3
-rw-r--r--multimedia/mp3cd/pkg-descr4
-rw-r--r--multimedia/mp3cd/pkg-plist3
5 files changed, 36 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 3d83bac8a1b0..0443ede538ca 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -167,6 +167,7 @@
SUBDIR += mmsrip
SUBDIR += moonlight
SUBDIR += motion
+ SUBDIR += mp3cd
SUBDIR += mpeg
SUBDIR += mpeg2codec
SUBDIR += mpeg2play
diff --git a/multimedia/mp3cd/Makefile b/multimedia/mp3cd/Makefile
new file mode 100644
index 000000000000..8d8dd42249c2
--- /dev/null
+++ b/multimedia/mp3cd/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: mp3cd
+# Date created: 2009-06-15
+# Whom: Sylvio Cesar <scjamorim@bsd.com.br>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mp3cd
+PORTVERSION= 1.026
+CATEGORIES= multimedia
+MASTER_SITES= http://outflux.net/software/pkgs/mp3cd/download/
+
+MAINTAINER= scjamorim@bsd.com.br
+COMMENT= Perl script that burns MP3 to audio CDs
+
+BUILD_DEPENDS= ${SITE_PERL}/Config/Simple.pm:${PORTSDIR}/devel/p5-Config-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PERL5= yes
+PERL_CONFIGURE= 5.8.0+
+
+MAN1= mp3cd.1
+MANCOMPRESS= yes
+
+.include <bsd.port.mk>
diff --git a/multimedia/mp3cd/distinfo b/multimedia/mp3cd/distinfo
new file mode 100644
index 000000000000..78a21b98ab31
--- /dev/null
+++ b/multimedia/mp3cd/distinfo
@@ -0,0 +1,3 @@
+MD5 (mp3cd-1.026.tar.gz) = 8f00eb0c8c97ca7510a974a696dc3ac9
+SHA256 (mp3cd-1.026.tar.gz) = d7521dabb835e174957a65ed806deb791620153e57605df21e8db22bbe139e02
+SIZE (mp3cd-1.026.tar.gz) = 19725
diff --git a/multimedia/mp3cd/pkg-descr b/multimedia/mp3cd/pkg-descr
new file mode 100644
index 000000000000..327da34b815a
--- /dev/null
+++ b/multimedia/mp3cd/pkg-descr
@@ -0,0 +1,4 @@
+mp3cd is a perl script that normalizes and burns MP3,
+OGG, and WAV files to audio CDs.
+
+WWW: http://outflux.net
diff --git a/multimedia/mp3cd/pkg-plist b/multimedia/mp3cd/pkg-plist
new file mode 100644
index 000000000000..bb70b32f7932
--- /dev/null
+++ b/multimedia/mp3cd/pkg-plist
@@ -0,0 +1,3 @@
+bin/mp3cd
+%%SITE_PERL%%/mach/auto/mp3cd/.packlist
+@dirrmtry %%SITE_PERL%%/mach/auto/mp3cd