aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/py-pyxmpp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/py-pyxmpp/Makefile')
-rw-r--r--net-im/py-pyxmpp/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/net-im/py-pyxmpp/Makefile b/net-im/py-pyxmpp/Makefile
index d50199e8d621..8447b7721c6c 100644
--- a/net-im/py-pyxmpp/Makefile
+++ b/net-im/py-pyxmpp/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pyxmpp
-PORTVERSION= 0.5
+PORTVERSION= 1.0.0
CATEGORIES= net-im python
MASTER_SITES= http://jabberstudio.2nw.net/pyxmpp/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,12 +14,18 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= ports@FreeBSD.org
COMMENT= A Python XMPP library
-LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2:install
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/libxml2.py:${PORTSDIR}/textproc/py-libxml2
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/libxml2.py:${PORTSDIR}/textproc/py-libxml2 \
+ ${PYTHON_SITELIBDIR}/dns/__init__.py:${PORTSDIR}/dns/py-dnspython \
+ ${PYTHON_SITELIBDIR}/M2Crypto/__init__.py:${PORTSDIR}/security/py-m2crypto
USE_PYTHON= 2.3+
USE_PYDISTUTILS= yes
+post-patch:
+ @${GREP} -lr '/usr/bin/python' ${WRKSRC} | \
+ ${XARGS} ${REINPLACE_CMD} -e "s!/usr/bin/python!${PYTHON_CMD}!"
+
post-install:
@${ECHO} "pyxmpp" > ${PYTHON_SITELIBDIR}/pyxmpp.pth