aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gaim-bangexec/Makefile2
-rw-r--r--net-im/gaim-extprefs/Makefile2
-rw-r--r--net-im/gaim-ignorance/Makefile2
-rw-r--r--net-im/gaim-slashexec/Makefile3
4 files changed, 6 insertions, 3 deletions
diff --git a/net-im/gaim-bangexec/Makefile b/net-im/gaim-bangexec/Makefile
index 1740b734838a..721d230d0404 100644
--- a/net-im/gaim-bangexec/Makefile
+++ b/net-im/gaim-bangexec/Makefile
@@ -26,6 +26,6 @@ GNU_CONFIGURE= yes
PLIST_FILES= lib/gaim/bangexec.la lib/gaim/bangexec.so
post-patch:
- @${REINPLACE_CMD} -e 's|-g3||' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-g3|| ; s|echo aout|echo elf|' ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/net-im/gaim-extprefs/Makefile b/net-im/gaim-extprefs/Makefile
index 1db0b358f2f1..f27b713bcf7e 100644
--- a/net-im/gaim-extprefs/Makefile
+++ b/net-im/gaim-extprefs/Makefile
@@ -27,6 +27,6 @@ CFLAGS+= "-fPIC"
PLIST_FILES= lib/gaim/libextprefs.la lib/gaim/libextprefs.so
post-patch:
- @${REINPLACE_CMD} -e 's/-g3//' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's/-g3// ; s|echo aout|echo elf|' ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/net-im/gaim-ignorance/Makefile b/net-im/gaim-ignorance/Makefile
index bba7aa20af45..72e7035079e2 100644
--- a/net-im/gaim-ignorance/Makefile
+++ b/net-im/gaim-ignorance/Makefile
@@ -27,7 +27,7 @@ SUB_FILES= pkg-message
PORTDOCS= README
post-patch:
- @${REINPLACE_CMD} -e 's|-g3||' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-g3|| ; s|echo aout|echo elf|' ${WRKSRC}/configure
@${REINPLACE_CMD} -e "s/ignorance.conf/ignorance.conf.sample/g" ${WRKSRC}/Makefile.in
@${MV} ${WRKSRC}/ignorance.conf ${WRKSRC}/ignorance.conf.sample
diff --git a/net-im/gaim-slashexec/Makefile b/net-im/gaim-slashexec/Makefile
index 4e69fc4d7007..f61f7971b499 100644
--- a/net-im/gaim-slashexec/Makefile
+++ b/net-im/gaim-slashexec/Makefile
@@ -23,4 +23,7 @@ GNU_CONFIGURE= yes
PLIST_FILES= lib/gaim/se.la lib/gaim/se.so
+post-patch:
+ @${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/configure
+
.include <bsd.port.mk>