aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/icli/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/icli/Makefile')
-rw-r--r--net-mgmt/icli/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-mgmt/icli/Makefile b/net-mgmt/icli/Makefile
new file mode 100644
index 000000000000..e3b47659c784
--- /dev/null
+++ b/net-mgmt/icli/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= icli
+DISTVERSION= 0.46
+CATEGORIES= net-mgmt perl5
+MASTER_SITES= http://finalrewind.org/projects/icli/
+
+MAINTAINER= lme@FreeBSD.org
+COMMENT= Command line interface to Icinga
+
+LICENSE= ICLI
+LICENSE_NAME= ICLI license
+LICENSE_FILE= ${WRKSRC}/COPYING
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+RUN_DEPENDS= p5-List-MoreUtils>=0:${PORTSDIR}/lang/p5-List-MoreUtils \
+ p5-Term-Size>=0:${PORTSDIR}/devel/p5-Term-Size \
+ icinga:${PORTSDIR}/net-mgmt/icinga
+
+CONFIGURE_ARGS+= --destdir ${STAGEDIR}
+
+USES= perl5
+USE_PERL5= modbuild
+
+PLIST_FILES= bin/${PORTNAME} man/man1/${PORTNAME}.1.gz
+
+post-patch:
+ @${REINPLACE_CMD} -i '' 's|/var/[^/]*/icinga|/var/spool/icinga|' \
+ ${WRKSRC}/bin/${PORTNAME}
+
+.include <bsd.port.mk>