aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/nfsen-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/nfsen-devel/Makefile')
-rw-r--r--net-mgmt/nfsen-devel/Makefile33
1 files changed, 15 insertions, 18 deletions
diff --git a/net-mgmt/nfsen-devel/Makefile b/net-mgmt/nfsen-devel/Makefile
index 4ccbe861d967..fecf1fc21a8e 100644
--- a/net-mgmt/nfsen-devel/Makefile
+++ b/net-mgmt/nfsen-devel/Makefile
@@ -1,23 +1,25 @@
-# New ports collection makefile for: nfsen
-# Date created: 25 March 2005
+# New ports collection makefile for: nfsen-devel
+# Date created: 21 May 2007
# Whom: janos.mohacsi@bsd.hu
#
# $FreeBSD$
#
PORTNAME= nfsen
-PORTVERSION= 1.2.4.20060810
+DISTVERSION= 20070312
CATEGORIES= net-mgmt
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
- http://nfsen.sourceforge.net/
-MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME}-snapshot-20060810
+MASTER_SITES= SF
+PKGNAMESUFFIX= -devel
+DISTNAME= nfsen-snapshot-${PORTVERSION}
MAINTAINER= janos.mohacsi@bsd.hu
-COMMENT= Web based frontend to nfdump netflow collector
+COMMENT= Development version of web based frontend to nfdump
-RUN_DEPENDS= ${SITE_PERL}/RRDp.pm:${PORTSDIR}/databases/rrdtool \
- nfdump:${PORTSDIR}/net-mgmt/nfdump
+RUN_DEPENDS= nfdump:${PORTSDIR}/net-mgmt/nfdump \
+ ${SITE_PERL}/Mail/Header.pm:${PORTSDIR}/mail/p5-Mail-Tools \
+ ${SITE_PERL}/RRDp.pm:${PORTSDIR}/databases/rrdtool
+
+CONFLICTS= nfsen-[0-9]*
USE_ICONV= yes
USE_PERL5= yes
@@ -26,12 +28,6 @@ NO_BUILD= yes
PLIST_SUB+= PORTNAME=${PORTNAME}
USE_RC_SUBR= nfsen.sh
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires at least perl 5.6.0
-.endif
-
pre-everything::
@${ECHO_MSG} ""
@${ECHO_MSG} "*****************************************************"
@@ -46,6 +42,7 @@ post-patch:
@${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},' -e 's,%%PORTNAME%%,${PORTNAME},' \
${WRKSRC}/etc/nfsen-dist.conf
@${RM} ${WRKSRC}/etc/nfsen-dist.conf.*
+ @${RM} ${WRKSRC}/bin/testPlugin.orig
@${REINPLACE_CMD} -e 's,%%PERL%%,${PERL},' -e 's,%%PREFIX%%,${PREFIX},' ${WRKSRC}/install.pl
do-install:
@@ -61,6 +58,6 @@ do-install:
cd ${WRKSRC} ;${PERL} ${WRKSRC}/install.pl ${WRKSRC}/etc/nfsen-dist.conf; \
fi
@${ECHO_MSG} "Configure your ${LOCALBASE}/etc/nfsen.conf to have necessary sources ";
- @${ECHO_MSG} "Then run 'nfsen -R ${LOCALBASE}/etc/nfsen.conf' to correctly setup source, RRD, and profile files";
+ @${ECHO_MSG} "Then run 'nfsen reconfig' to correctly setup source, RRD, and profile files";
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>