aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/zabbix42-frontend/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/zabbix42-frontend/Makefile')
-rw-r--r--net-mgmt/zabbix42-frontend/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-mgmt/zabbix42-frontend/Makefile b/net-mgmt/zabbix42-frontend/Makefile
new file mode 100644
index 000000000000..00e042f6d963
--- /dev/null
+++ b/net-mgmt/zabbix42-frontend/Makefile
@@ -0,0 +1,34 @@
+# Created by: Pakhom Golynga <pg@pakhom.spb.ru>
+# $FreeBSD$
+
+PORTNAME= zabbix42
+CATEGORIES= net-mgmt
+PKGNAMESUFFIX= -frontend
+
+MASTERDIR= ${.CURDIR}/../zabbix42-server
+
+NO_BUILD= yes
+NO_ARCH= yes
+PATCHDIR=
+PLIST= ${PKGDIR}/pkg-plist.frontend
+
+USE_PHP= bcmath ctype dom filter gd gettext json ldap mbstring pcre \
+ session simplexml snmp sockets xml xmlreader xmlwriter
+USES+= php:web
+
+OPTIONS_DEFINE= MYSQLI PGSQL ORACLE
+OPTIONS_DEFAULT= MYSQLI
+MYSQLI_DESC= MySQLI backend
+
+MYSQLI_USE= PHP=mysqli
+
+PGSQL_USE= PHP=pgsql
+
+ORACLE_CONFIGURE_WITH= oracle
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${WWWDIR}
+ (cd ${WRKSRC}/frontends/php && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR})
+
+.include "${MASTERDIR}/Makefile"