aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/xymon-server/Makefile2
-rw-r--r--net-mgmt/xymon-server/files/Makefile7
2 files changed, 8 insertions, 1 deletions
diff --git a/net-mgmt/xymon-server/Makefile b/net-mgmt/xymon-server/Makefile
index 2ac8e08ba64f..5032f0ccfd61 100644
--- a/net-mgmt/xymon-server/Makefile
+++ b/net-mgmt/xymon-server/Makefile
@@ -29,7 +29,7 @@ XYMONUSER?= xymon
XYMONHOSTNAME?= xymon.example.com
XYMONHOSTIP?= 127.0.0.1
-USES= cpe gmake shebangfix ssl
+USES= compiler:c11 cpe gmake shebangfix ssl
SHEBANG_FILES= ${WRKSRC}/xymond/xymonreports.sh.DIST ${WRKSRC}/build/upgrade430.sh
MAKE_JOBS_UNSAFE= yes
CONFIGURE_ENV= MAKE=gmake
diff --git a/net-mgmt/xymon-server/files/Makefile b/net-mgmt/xymon-server/files/Makefile
index 86c0428a3529..7de4abe9114b 100644
--- a/net-mgmt/xymon-server/files/Makefile
+++ b/net-mgmt/xymon-server/files/Makefile
@@ -60,9 +60,14 @@ DORRD = yes
#
# OpenSSL settings
SSLFLAGS = -DHAVE_OPENSSL
+
+ifneq (${OPENSSLLIB},/usr/lib)
SSLINCDIR = -I${OPENSSLINC}
SSLLIBS = -L${OPENSSLLIB} -lssl -lcrypto
RPATHVAL += ${OPENSSLLIB}
+else
+SSLLIBS = -lssl -lcrypto
+endif
DOSSL = yes
#
ifdef WITH_LDAP
@@ -70,7 +75,9 @@ ifdef WITH_LDAP
LDAPFLAGS = -DXYMON_LDAP -DXYMON_LDAP_USESTARTTLS -DHAVE_LDAP
LDAPINCDIR = -I${PREFIX}/include
LDAPLIBS = -L${PREFIX}/lib -lldap -llber
+ifneq (${OPENSSLLIB},/usr/lib)
RPATHVAL += ${PREFIX}/lib
+endif
RPATHVAL += /usr/local/lib
DOLDAP = yes
endif