aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/zenpack-graphportlet/Makefile25
-rw-r--r--net-mgmt/zenpack-graphportlet/distinfo2
-rw-r--r--net-mgmt/zenpack-graphportlet/files/pkg-deinstall.in10
-rw-r--r--net-mgmt/zenpack-graphportlet/files/pkg-message.in5
-rw-r--r--net-mgmt/zenpack-graphportlet/pkg-descr7
-rw-r--r--net-mgmt/zenpack-graphportlet/pkg-plist2
7 files changed, 52 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index ba6ebe850d67..277e397c14f3 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -301,6 +301,7 @@
SUBDIR += zenpack-dellmon
SUBDIR += zenpack-deviceadvdetail
SUBDIR += zenpack-devicesearch
+ SUBDIR += zenpack-graphportlet
SUBDIR += zenpack-interfacegraphs
SUBDIR += zenpack-macreport
diff --git a/net-mgmt/zenpack-graphportlet/Makefile b/net-mgmt/zenpack-graphportlet/Makefile
new file mode 100644
index 000000000000..a3f1ffe2ce87
--- /dev/null
+++ b/net-mgmt/zenpack-graphportlet/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: ShowGraphPortlet
+# Date created: 12 May 2011
+# Whom: Zenoss <zenoss@experts-exchange.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ShowGraphPortlet
+PORTVERSION= 1.03
+CATEGORIES= net-mgmt www
+MASTER_SITES= http://zenpacks.zenoss.org/trac-zenpacks/changeset/1002/tags/
+DISTFILES= graph-portlet-${PORTVERSION}?old_path=%2F\&format=zip
+
+MAINTAINER= zenoss@experts-exchange.com
+COMMENT= Enables users to show any graph/multi graph reports on their dashboard
+
+USE_ZIP= yes
+ZPACKGROUP= community
+WRKSRC= ${WRKDIR}/tags/graph-portlet-${PORTVERSION}/
+
+ZPACKPREFIX= ZenPacks.SCC.
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/Mk/bsd.zenoss.mk"
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/zenpack-graphportlet/distinfo b/net-mgmt/zenpack-graphportlet/distinfo
new file mode 100644
index 000000000000..2b04db2790a8
--- /dev/null
+++ b/net-mgmt/zenpack-graphportlet/distinfo
@@ -0,0 +1,2 @@
+SHA256 (graph-portlet-1.03?old_path=%2F&format=zip) = 69d89200f437f0b80d9d1508d4b550677a49037ac15dc8a98bfe542299c590e1
+SIZE (graph-portlet-1.03?old_path=%2F&format=zip) = 7289
diff --git a/net-mgmt/zenpack-graphportlet/files/pkg-deinstall.in b/net-mgmt/zenpack-graphportlet/files/pkg-deinstall.in
new file mode 100644
index 000000000000..a1f84ae8e2cf
--- /dev/null
+++ b/net-mgmt/zenpack-graphportlet/files/pkg-deinstall.in
@@ -0,0 +1,10 @@
+#!/bin/sh
+
+if [ "$2" = "DEINSTALL" ]; then
+ echo "To de-activate this Zenpack, run the following command as the zenoss user:
+
+%%ZENHOME%%/bin/zenpack --remove %%ZPACKPREFIX%%%%PORTNAME%%
+
+IMPORTANT: De-activating a Zenpack will also remove all its associated data"
+
+fi
diff --git a/net-mgmt/zenpack-graphportlet/files/pkg-message.in b/net-mgmt/zenpack-graphportlet/files/pkg-message.in
new file mode 100644
index 000000000000..869bea811264
--- /dev/null
+++ b/net-mgmt/zenpack-graphportlet/files/pkg-message.in
@@ -0,0 +1,5 @@
+
+To activate this Zenpack, run the following commands as the zenoss user:
+
+%%ZENHOME%%/bin/zenpack --install %%ZPACKHOME%%/%%ZPACK%%
+%%ZENHOME%%/bin/zopectl restart
diff --git a/net-mgmt/zenpack-graphportlet/pkg-descr b/net-mgmt/zenpack-graphportlet/pkg-descr
new file mode 100644
index 000000000000..f1b6f35c7590
--- /dev/null
+++ b/net-mgmt/zenpack-graphportlet/pkg-descr
@@ -0,0 +1,7 @@
+This ZenPack adds a portlet called "Show Graph" which enables users to show any
+graph/multi graph reports on their dashboard. Several columns (as defined in
+report options) are supported.
+
+More details can be found at the provided url.
+
+WWW: http://community.zenoss.org/docs/DOC-3421
diff --git a/net-mgmt/zenpack-graphportlet/pkg-plist b/net-mgmt/zenpack-graphportlet/pkg-plist
new file mode 100644
index 000000000000..52307ea0055e
--- /dev/null
+++ b/net-mgmt/zenpack-graphportlet/pkg-plist
@@ -0,0 +1,2 @@
+zenoss/ZenPack/%%ZPACK%%
+@dirrmtry zenoss/ZenPack