aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/gift-fasttrack/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/gift-fasttrack/Makefile')
-rw-r--r--net-p2p/gift-fasttrack/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-p2p/gift-fasttrack/Makefile b/net-p2p/gift-fasttrack/Makefile
new file mode 100644
index 000000000000..bec42d362334
--- /dev/null
+++ b/net-p2p/gift-fasttrack/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: giFT-FastTrack
+# Date created: 2003-09-04
+# Whom: Stefan Ehmann <shoesoft@gmx.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= giFT-FastTrack
+PORTVERSION= 0.8.3
+CATEGORIES= net
+MASTER_SITES= http://download.berlios.de/gift-fasttrack/
+
+MAINTAINER= shoesoft@gmx.net
+COMMENT= A FastTrack plugin for giFT
+
+LIB_DEPENDS= gift.0:${PORTSDIR}/net/gift
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+
+DOC_FILES= AUTHORS COPYING ChangeLog \
+ INSTALL NEWS README TODO
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for doc in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>