aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/litecoin
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/litecoin')
-rw-r--r--net-p2p/litecoin/Makefile12
-rw-r--r--net-p2p/litecoin/distinfo4
-rw-r--r--net-p2p/litecoin/files/extra-patch-endian47
-rw-r--r--net-p2p/litecoin/files/patch-bitcoin-qt.pro6
-rw-r--r--net-p2p/litecoin/files/patch-src__makefile.unix (renamed from net-p2p/litecoin/files/patch-src-makefile.unix)18
-rw-r--r--net-p2p/litecoin/files/patch-src__scrypt.cpp33
-rw-r--r--net-p2p/litecoin/files/patch-src__scrypt.h22
7 files changed, 74 insertions, 68 deletions
diff --git a/net-p2p/litecoin/Makefile b/net-p2p/litecoin/Makefile
index f0549d53f139..526c70755e1d 100644
--- a/net-p2p/litecoin/Makefile
+++ b/net-p2p/litecoin/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= litecoin
-PORTVERSION= 0.8.6.1
-PORTREVISION= 2
+PORTVERSION= 0.8.6.2
CATEGORIES= net-p2p finance
MASTER_SITES= LOCAL/swills \
GH
@@ -15,7 +14,7 @@ LIB_DEPENDS= libboost_date_time.so:${PORTSDIR}/devel/boost-libs
USE_GITHUB= yes
GH_ACCOUNT= litecoin-project
-GH_COMMIT= dab8fe6
+GH_COMMIT= fa2cfea
GH_TAGNAME= v${PORTVERSION}
USE_OPENSSL= yes
@@ -44,7 +43,8 @@ QMAKE_USE_UPNP= -
.endif
.if ${PORT_OPTIONS:MX11}
-USE_QT4= qmake_build linguist uic moc rcc
+USE_QT4= network gui qmake_build linguist_build uic_build moc_build rcc_build
+
BINARY= litecoin-qt
.else
BINARY= litecoind
@@ -75,10 +75,6 @@ QMAKE_USE_DBUS= 0
PLIST_FILES+= share/applications/litecoin-qt.desktop share/pixmaps/litecoin64.png
.endif
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000054
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-endian
-.endif
-
do-configure:
.if ${PORT_OPTIONS:MX11}
cd ${BUILD_WRKSRC} && \
diff --git a/net-p2p/litecoin/distinfo b/net-p2p/litecoin/distinfo
index d417bf458f89..ef46c993a379 100644
--- a/net-p2p/litecoin/distinfo
+++ b/net-p2p/litecoin/distinfo
@@ -1,2 +1,2 @@
-SHA256 (litecoin-0.8.6.1.tar.gz) = ff11a4d5bd0cf9ddac0b1644d0819ec3d6827e5052addcbc871d288286188019
-SIZE (litecoin-0.8.6.1.tar.gz) = 4807148
+SHA256 (litecoin-0.8.6.2.tar.gz) = 74aabe6e02e8adfadcb982f2cab542248c991ceb7e9ec84db9d99e6886761b9a
+SIZE (litecoin-0.8.6.2.tar.gz) = 4806869
diff --git a/net-p2p/litecoin/files/extra-patch-endian b/net-p2p/litecoin/files/extra-patch-endian
deleted file mode 100644
index 8a016d89daad..000000000000
--- a/net-p2p/litecoin/files/extra-patch-endian
+++ /dev/null
@@ -1,47 +0,0 @@
---- src/scrypt.cpp.orig 2013-12-09 18:10:12.046606050 +0000
-+++ src/scrypt.cpp 2013-12-09 18:10:25.898605023 +0000
-@@ -34,22 +34,6 @@
- #include <string.h>
- #include <openssl/sha.h>
-
--static inline uint32_t be32dec(const void *pp)
--{
-- const uint8_t *p = (uint8_t const *)pp;
-- return ((uint32_t)(p[3]) + ((uint32_t)(p[2]) << 8) +
-- ((uint32_t)(p[1]) << 16) + ((uint32_t)(p[0]) << 24));
--}
--
--static inline void be32enc(void *pp, uint32_t x)
--{
-- uint8_t *p = (uint8_t *)pp;
-- p[3] = x & 0xff;
-- p[2] = (x >> 8) & 0xff;
-- p[1] = (x >> 16) & 0xff;
-- p[0] = (x >> 24) & 0xff;
--}
--
- typedef struct HMAC_SHA256Context {
- SHA256_CTX ictx;
- SHA256_CTX octx;
---- src/scrypt.h.orig 2013-12-09 15:26:17.343282984 +0000
-+++ src/scrypt.h 2013-12-09 15:45:11.032205545 +0000
-@@ -17,19 +17,4 @@
- PBKDF2_SHA256(const uint8_t *passwd, size_t passwdlen, const uint8_t *salt,
- size_t saltlen, uint64_t c, uint8_t *buf, size_t dkLen);
-
--static inline uint32_t le32dec(const void *pp)
--{
-- const uint8_t *p = (uint8_t const *)pp;
-- return ((uint32_t)(p[0]) + ((uint32_t)(p[1]) << 8) +
-- ((uint32_t)(p[2]) << 16) + ((uint32_t)(p[3]) << 24));
--}
--
--static inline void le32enc(void *pp, uint32_t x)
--{
-- uint8_t *p = (uint8_t *)pp;
-- p[0] = x & 0xff;
-- p[1] = (x >> 8) & 0xff;
-- p[2] = (x >> 16) & 0xff;
-- p[3] = (x >> 24) & 0xff;
--}
- #endif
diff --git a/net-p2p/litecoin/files/patch-bitcoin-qt.pro b/net-p2p/litecoin/files/patch-bitcoin-qt.pro
index 125cbfe16156..c166e821a8da 100644
--- a/net-p2p/litecoin/files/patch-bitcoin-qt.pro
+++ b/net-p2p/litecoin/files/patch-bitcoin-qt.pro
@@ -1,6 +1,6 @@
---- bitcoin-qt.pro.orig 2013-07-21 17:42:52.047209171 +0000
-+++ bitcoin-qt.pro 2013-07-21 17:43:11.879205795 +0000
-@@ -414,7 +414,7 @@
+--- ./bitcoin-qt.pro.orig 2014-01-10 01:38:53.000000000 +0000
++++ ./bitcoin-qt.pro 2014-02-09 05:45:03.127008564 +0000
+@@ -431,7 +431,7 @@
LIBS += -lssl -lcrypto -ldb_cxx$$BDB_LIB_SUFFIX
# -lgdi32 has to happen after -lcrypto (see #681)
win32:LIBS += -lws2_32 -lshlwapi -lmswsock -lole32 -loleaut32 -luuid -lgdi32
diff --git a/net-p2p/litecoin/files/patch-src-makefile.unix b/net-p2p/litecoin/files/patch-src__makefile.unix
index a9c89cb68998..05e3431ad33c 100644
--- a/net-p2p/litecoin/files/patch-src-makefile.unix
+++ b/net-p2p/litecoin/files/patch-src__makefile.unix
@@ -1,13 +1,13 @@
---- src/makefile.unix.orig 2012-07-26 07:55:22.000000000 +0000
-+++ src/makefile.unix 2013-05-30 03:57:45.000000000 +0000
-@@ -6,6 +6,11 @@
+--- ./src/makefile.unix.orig 2014-01-10 01:38:53.000000000 +0000
++++ ./src/makefile.unix 2014-02-09 05:45:03.135007077 +0000
+@@ -15,6 +15,11 @@
- DEFS=-DUSE_IPV6 -DBOOST_SPIRIT_THREADSAFE
+ DEFS=-DBOOST_SPIRIT_THREADSAFE -D_FILE_OFFSET_BITS=64
-+BOOST_INCLUDE_PATH=%%LOCALBASE%%/include
-+BDB_INCLUDE_PATH=%%LOCALBASE%%/include/db48
-+BOOST_LIB_PATH=%%LOCALBASE%%/lib
-+BDB_LIB_PATH=%%LOCALBASE%%/lib/db48
++BOOST_INCLUDE_PATH=/usr/local/include
++BDB_INCLUDE_PATH=/usr/local/include/db48
++BOOST_LIB_PATH=/usr/local/lib
++BDB_LIB_PATH=/usr/local/lib/db48
+
DEFS += $(addprefix -I,$(CURDIR) $(CURDIR)/obj $(BOOST_INCLUDE_PATH) $(BDB_INCLUDE_PATH) $(OPENSSL_INCLUDE_PATH))
LIBS = $(addprefix -L,$(BOOST_LIB_PATH) $(BDB_LIB_PATH) $(OPENSSL_LIB_PATH))
@@ -26,3 +26,5 @@
-l z \
- -l dl \
-l pthread
+
+
diff --git a/net-p2p/litecoin/files/patch-src__scrypt.cpp b/net-p2p/litecoin/files/patch-src__scrypt.cpp
new file mode 100644
index 000000000000..4bb49b8a7ffd
--- /dev/null
+++ b/net-p2p/litecoin/files/patch-src__scrypt.cpp
@@ -0,0 +1,33 @@
+--- ./src/scrypt.cpp.orig 2014-01-10 01:38:53.000000000 +0000
++++ ./src/scrypt.cpp 2014-02-09 05:45:03.131006405 +0000
+@@ -33,6 +33,7 @@
+ #include <stdint.h>
+ #include <string.h>
+ #include <openssl/sha.h>
++#include <boost/lexical_cast.hpp>
+
+ #if defined(USE_SSE2) && !defined(USE_SSE2_ALWAYS)
+ #ifdef _MSC_VER
+@@ -44,22 +45,6 @@
+ #endif
+ #endif
+
+-static inline uint32_t be32dec(const void *pp)
+-{
+- const uint8_t *p = (uint8_t const *)pp;
+- return ((uint32_t)(p[3]) + ((uint32_t)(p[2]) << 8) +
+- ((uint32_t)(p[1]) << 16) + ((uint32_t)(p[0]) << 24));
+-}
+-
+-static inline void be32enc(void *pp, uint32_t x)
+-{
+- uint8_t *p = (uint8_t *)pp;
+- p[3] = x & 0xff;
+- p[2] = (x >> 8) & 0xff;
+- p[1] = (x >> 16) & 0xff;
+- p[0] = (x >> 24) & 0xff;
+-}
+-
+ typedef struct HMAC_SHA256Context {
+ SHA256_CTX ictx;
+ SHA256_CTX octx;
diff --git a/net-p2p/litecoin/files/patch-src__scrypt.h b/net-p2p/litecoin/files/patch-src__scrypt.h
new file mode 100644
index 000000000000..f66841aa2886
--- /dev/null
+++ b/net-p2p/litecoin/files/patch-src__scrypt.h
@@ -0,0 +1,22 @@
+--- ./src/scrypt.h.orig 2014-01-10 01:38:53.000000000 +0000
++++ ./src/scrypt.h 2014-02-09 05:45:03.133009188 +0000
+@@ -27,19 +27,4 @@
+ PBKDF2_SHA256(const uint8_t *passwd, size_t passwdlen, const uint8_t *salt,
+ size_t saltlen, uint64_t c, uint8_t *buf, size_t dkLen);
+
+-static inline uint32_t le32dec(const void *pp)
+-{
+- const uint8_t *p = (uint8_t const *)pp;
+- return ((uint32_t)(p[0]) + ((uint32_t)(p[1]) << 8) +
+- ((uint32_t)(p[2]) << 16) + ((uint32_t)(p[3]) << 24));
+-}
+-
+-static inline void le32enc(void *pp, uint32_t x)
+-{
+- uint8_t *p = (uint8_t *)pp;
+- p[0] = x & 0xff;
+- p[1] = (x >> 8) & 0xff;
+- p[2] = (x >> 16) & 0xff;
+- p[3] = (x >> 24) & 0xff;
+-}
+ #endif