aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/retroshare/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/retroshare/Makefile')
-rw-r--r--net-p2p/retroshare/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/net-p2p/retroshare/Makefile b/net-p2p/retroshare/Makefile
index 4aed3d98ca6c..9923d2d0114b 100644
--- a/net-p2p/retroshare/Makefile
+++ b/net-p2p/retroshare/Makefile
@@ -2,8 +2,9 @@
# $FreeBSD$
PORTNAME= retroshare
-PORTVERSION= 0.6.0
+PORTVERSION= 0.6.0e
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= net-p2p
MAINTAINER= peter@netkey.at
@@ -23,7 +24,7 @@ LIB_DEPENDS= libsqlcipher.so:databases/sqlcipher \
libcurl.so:ftp/curl \
libmicrohttpd.so:www/libmicrohttpd
-USES= qmake compiler:features dos2unix execinfo pkgconfig
+USES= compiler:features desktop-file-utils dos2unix execinfo pkgconfig qmake ssl
USE_GNOME= glib20 libxml2 libxslt
USE_GL= gl
USE_QT5= buildtools_build uitools_build core gui network xml \
@@ -34,6 +35,7 @@ DOS2UNIX_FILES= retroshare-nogui/src/retroshare-nogui.pro
USE_GITHUB= yes
GH_ACCOUNT= RetroShare
GH_PROJECT= RetroShare
+GH_TAGNAME= 9f7ef8b
.include <bsd.port.pre.mk>
@@ -52,5 +54,9 @@ post-patch:
${WRKSRC}/data/retroshare06.desktop
@${REINPLACE_CMD} -e 's|/usr/share|${PREFIX}/share|' \
${WRKSRC}/data/retroshare06.desktop
+.if defined(GH_TAGNAME)
+ @${REINPLACE_CMD} -e 's|01234567|0${GH_TAGNAME}|' \
+ ${WRKSRC}/libretroshare/src/retroshare/rsversion.h
+.endif
.include <bsd.port.post.mk>