aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/zetacoin-daemon/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/zetacoin-daemon/Makefile')
-rw-r--r--net-p2p/zetacoin-daemon/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-p2p/zetacoin-daemon/Makefile b/net-p2p/zetacoin-daemon/Makefile
new file mode 100644
index 000000000000..205d27a9640b
--- /dev/null
+++ b/net-p2p/zetacoin-daemon/Makefile
@@ -0,0 +1,37 @@
+# Created by: Daniel Morante <daniel@morante.net>
+# $FreeBSD$
+
+MASTERDIR= ${.CURDIR}/../zetacoin
+PKGNAMESUFFIX= -daemon
+
+COMMENT= Peer-to-Peer crypto currency with quick transactions (Daemon)
+
+SLAVE_PORT= yes
+
+RUN_DEPENDS+= zetacoin-cli:net-p2p/zetacoin-utils
+
+OPTIONS_DEFINE= DEBUG HARDENING TESTS UPNP ZMQ
+# WALLET_BDBMODERN is a choice for WALLET, introduced via OPTIONS_RADIO=WALLET
+# from ${MASTERDIR}/Makefile
+OPTIONS_DEFAULT= HARDENING UPNP WALLET_BDBMODERN ZMQ
+
+USERS= ${PORTNAME}
+GROUPS= ${PORTNAME}
+
+CONFIGURE_ARGS= --with-daemon \
+ --without-gui \
+ --without-libs \
+ --without-qrencode \
+ --without-utils
+
+PLIST_FILES= bin/${PORTNAME}d \
+ "@sample %%ETCDIR%%.conf.sample"
+
+USE_RC_SUBR= ${PORTNAME}
+SUB_LIST+= PORTNAME=${PORTNAME}
+SUB_FILES= pkg-message
+
+post-install:
+ ${INSTALL_DATA} ${FILESDIR}/${PORTNAME}.conf ${STAGEDIR}${PREFIX}/etc/${PORTNAME}.conf.sample
+
+.include "${MASTERDIR}/Makefile"