aboutsummaryrefslogtreecommitdiffstats
path: root/net/GeoIP/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/GeoIP/Makefile')
-rw-r--r--net/GeoIP/Makefile18
1 files changed, 8 insertions, 10 deletions
diff --git a/net/GeoIP/Makefile b/net/GeoIP/Makefile
index 52c7bf5c3fda..9a1ee7be1576 100644
--- a/net/GeoIP/Makefile
+++ b/net/GeoIP/Makefile
@@ -2,28 +2,26 @@
# $FreeBSD$
PORTNAME= GeoIP
-PORTVERSION= 1.4.8
-PORTREVISION= 7
+PORTVERSION= 1.6.0
CATEGORIES= net geography
MASTER_SITES= http://geolite.maxmind.com/download/geoip/api/c/
MAINTAINER= adamw@FreeBSD.org
COMMENT= Find the country that any IP address or hostname originates from
-GNU_CONFIGURE= yes
-USES= libtool:oldver
-USE_LDCONFIG= yes
+USES= libtool:oldver pathfix
USE_AUTOTOOLS= aclocal automake libtoolize autoconf
AUTOMAKE_ARGS= --add-missing
+PATHFIX_MAKEFILEIN= Makefile.am
+
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
SUB_FILES= geoipupdate.sh pkg-message
post-install:
${INSTALL_SCRIPT} ${WRKDIR}/geoipupdate.sh ${STAGEDIR}${PREFIX}/bin
- ${MV} ${STAGEDIR}${DATADIR}/GeoIP.dat \
- ${STAGEDIR}${DATADIR}/GeoIP.dat.sample
- ${MV} ${STAGEDIR}${PREFIX}/etc/GeoIP.conf.default \
- ${STAGEDIR}${PREFIX}/etc/GeoIP.conf.sample
- ${RM} ${STAGEDIR}${PREFIX}/etc/GeoIP.conf
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libGeoIP.so.*
+ @${MKDIR} ${STAGEDIR}${DATADIR}
.include <bsd.port.mk>