aboutsummaryrefslogtreecommitdiffstats
path: root/net/arping/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/arping/Makefile')
-rw-r--r--net/arping/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/net/arping/Makefile b/net/arping/Makefile
index 6d252be275c8..524f57fccbb6 100644
--- a/net/arping/Makefile
+++ b/net/arping/Makefile
@@ -7,29 +7,29 @@
PORTNAME= arping
PORTVERSION= 2.05
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= ftp://ftp.habets.pp.se/pub/synscan/
MAINTAINER= gavin.atkinson@ury.york.ac.uk
COMMENT= ARP level "ping" utility
-BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet10
+BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
LDFLAGS+= -lpcap
MAN8= arping.8
PLIST_FILES= sbin/arping
-LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet10-config
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
do-build:
cd ${WRKSRC} && \
${CC} ${CFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib \
- -DUSE_NETIF=1 -DFREEBSD=1 -c `${LIBNET_CONFIG} --defines` \
- `${LIBNET_CONFIG} --cflags` ${PORTNAME}.c && \
+ -c `${LIBNET_CONFIG} --defines` \
+ `${LIBNET_CONFIG} --cflags` ${PORTNAME}-2/${PORTNAME}.c && \
${CC} ${CFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib \
- -DUSE_NETIF=1 -DFREEBSD=1 -o ${PORTNAME} ${PORTNAME}.o \
+ -o ${PORTNAME} ${PORTNAME}.o \
`${LIBNET_CONFIG} --libs` ${LDFLAGS}
do-install: