aboutsummaryrefslogtreecommitdiffstats
path: root/net/arpoison
diff options
context:
space:
mode:
Diffstat (limited to 'net/arpoison')
-rw-r--r--net/arpoison/Makefile23
-rw-r--r--net/arpoison/distinfo3
-rw-r--r--net/arpoison/files/patch-Makefile11
-rw-r--r--net/arpoison/pkg-descr6
4 files changed, 43 insertions, 0 deletions
diff --git a/net/arpoison/Makefile b/net/arpoison/Makefile
new file mode 100644
index 000000000000..180b2c22f3e8
--- /dev/null
+++ b/net/arpoison/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= arpoison
+DISTVERSION= 0.7
+CATEGORIES= net
+MASTER_SITES= http://www.arpoison.net/
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= UNIX arp cache update utility
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libnet.so:net/libnet
+
+USES= gmake
+
+PLIST_FILES= bin/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/net/arpoison/distinfo b/net/arpoison/distinfo
new file mode 100644
index 000000000000..068f0c344f95
--- /dev/null
+++ b/net/arpoison/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1563916540
+SHA256 (arpoison-0.7.tar.gz) = 63571633826e413a9bdaab760425d0fab76abaf71a2b7ff6a00d1de53d83e741
+SIZE (arpoison-0.7.tar.gz) = 8458
diff --git a/net/arpoison/files/patch-Makefile b/net/arpoison/files/patch-Makefile
new file mode 100644
index 000000000000..4f86753b6bb1
--- /dev/null
+++ b/net/arpoison/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig 2019-07-23 21:17:28 UTC
++++ Makefile
+@@ -2,7 +2,7 @@ all: arpoison
+
+ arpoison: arpoison.c
+
+- gcc -lnet -o arpoison `libnet-config --defines` -I/opt/local/include -L/opt/local/lib arpoison.c
++ $(CC) -o arpoison `libnet-config --defines --cflags --libs` arpoison.c
+
+ clean:
+
diff --git a/net/arpoison/pkg-descr b/net/arpoison/pkg-descr
new file mode 100644
index 000000000000..09b2d04bd368
--- /dev/null
+++ b/net/arpoison/pkg-descr
@@ -0,0 +1,6 @@
+arpoison sends out a custom ARP REPLY packet with the hardware and
+protocol address information of your choosing. Since ARP is a stateless
+protocol, most operating systems will gladly update their ARP cache with
+whatever information you send them in your hand-crafted packet.
+
+WWW: http://www.arpoison.net/