aboutsummaryrefslogtreecommitdiffstats
path: root/net/forg/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/forg/Makefile')
-rw-r--r--net/forg/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/net/forg/Makefile b/net/forg/Makefile
new file mode 100644
index 000000000000..70636123656d
--- /dev/null
+++ b/net/forg/Makefile
@@ -0,0 +1,31 @@
+# ex:ts=8
+# New ports collection makefile for: forg
+# Date created: Sep 25, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= forg
+PORTVERSION= 0.5.1
+CATEGORIES= net python
+MASTER_SITES= http://opop.nols.com/proggie/
+
+MAINTAINER= ports@FreeBSD.org
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter \
+ ${PYTHON_SITELIBDIR}/Pmw:${PORTSDIR}/x11-toolkits/pmw
+
+USE_PYTHON= yes
+NO_BUILD= yes
+
+post-patch:
+.for file in forg.py mini-forg.py
+ @${PERL} -pi -e "s,/usr/bin/python,${PYTHON_CMD},g" ${WRKSRC}/${file}
+.endfor
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/forg.py ${PREFIX}/bin/forg
+ ${CP} ${WRKSRC}/*.py ${PYTHON_SITELIBDIR}
+
+.include <bsd.port.mk>