aboutsummaryrefslogtreecommitdiffstats
path: root/net/ipa_ipfw/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/ipa_ipfw/Makefile')
-rw-r--r--net/ipa_ipfw/Makefile17
1 files changed, 4 insertions, 13 deletions
diff --git a/net/ipa_ipfw/Makefile b/net/ipa_ipfw/Makefile
index d2d59703cc17..0b4f6350875e 100644
--- a/net/ipa_ipfw/Makefile
+++ b/net/ipa_ipfw/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ipa_ipfw
-PORTVERSION= 1.0.2
+PORTVERSION= 1.1
CATEGORIES= net
MASTER_SITES= SF/ipa-system/modules/ipa_ipfw
@@ -20,14 +20,10 @@ NO_PACKAGE= Needs to be built uniquely for each host
USE_BZIP2= yes
USE_LDCONFIG= yes
-OPTIONS= DEBUG_INFO "Produce debugging info" off \
- MAN_KOI8_R "Install Russian manual pages" off
-
.include <bsd.port.pre.mk>
-.if !defined(WITH_DEBUG_INFO)
-MAKE_ENV+= DEBUG_FLAGS=""
-.endif
+LOCALINCLUDE?= ${LOCALBASE}/include
+MAKE_ENV+= DEBUG_FLAGS="" PREFIX=${PREFIX} LOCALINCLUDE=${LOCALINCLUDE}
BUILD_DEPENDS+= ${LOCALBASE}/include/ipa_mod.h:${PORTSDIR}/sysutils/ipa
@@ -35,15 +31,10 @@ PLIST_FILES= lib/ipa_ipfw.so
MANCOMPRESSED= yes
MAN8= ipa_ipfw.8
-MANLANG= ""
-.if defined(WITH_MAN_KOI8_R)
-MANLANG+= ru.KOI8-R
-.endif
+MANLANG= "" ru.KOI8-R
do-install:
cd ${WRKSRC} && ${MAKE} install
-.if defined(WITH_MAN_KOI8_R)
cd ${WRKSRC}/man && ${MAKE} LANG_DIR_SRC=ru.KOI8-R clean all install
-.endif
.include <bsd.port.post.mk>