aboutsummaryrefslogtreecommitdiffstats
path: root/net/jrobin/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/jrobin/Makefile')
-rw-r--r--net/jrobin/Makefile44
1 files changed, 0 insertions, 44 deletions
diff --git a/net/jrobin/Makefile b/net/jrobin/Makefile
deleted file mode 100644
index 124a3a63573f..000000000000
--- a/net/jrobin/Makefile
+++ /dev/null
@@ -1,44 +0,0 @@
-# ex:ts=8
-# Ports collection makefile for: JRobin
-# Date created: Mar 9, 2005
-# Whom: ijliao
-#
-# $FreeBSD$
-#
-
-PORTNAME= jrobin
-PORTVERSION= 1.5.4
-PORTREVISION= 1
-CATEGORIES= net java
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME}-${PORTVERSION}-1
-
-MAINTAINER= nemoliu@FreeBSD.org
-COMMENT= A pure Java alternative to RRDTool
-
-USE_JAVA= yes
-USE_ANT= yes
-JAVA_VERSION= 1.5+
-ALL_TARGET= dist
-WRKSRC= ${WRKDIR}/JRobinLite-${PORTVERSION}
-BUILD_WRKSRC= ${WRKSRC}/ant
-
-.if !defined(NOPORTDOCS)
-ALL_TARGET+= javadoc
-PORTDOCS= *
-.endif
-
-CLASSES= jrobin convertor inspector
-
-do-install:
-.for c in ${CLASSES}
- ${INSTALL_DATA} ${WRKSRC}/lib/${c}-${PORTVERSION}.jar ${JAVAJARDIR}/${c}.jar
- @${ECHO} '${JAVAJARDIR:S,^${PREFIX}/,,}/${c}.jar' >> ${TMPPLIST}
-.endfor
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${CP} -R ${WRKSRC}/doc/ ${DOCSDIR}
-.endif
-
-.include <bsd.port.mk>