aboutsummaryrefslogtreecommitdiffstats
path: root/net/kf5-kcalendarcore/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/kf5-kcalendarcore/Makefile')
-rw-r--r--net/kf5-kcalendarcore/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/net/kf5-kcalendarcore/Makefile b/net/kf5-kcalendarcore/Makefile
new file mode 100644
index 000000000000..457c63bae071
--- /dev/null
+++ b/net/kf5-kcalendarcore/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= kcalendarcore
+DISTVERSION= ${KDE_FRAMEWORKS_VERSION}
+PORTEPOCH= 1
+CATEGORIES= net kde kde-frameworks
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KDE calendar access library
+
+LICENSE= LGPL21
+
+LIB_DEPENDS= libical.so:devel/libical
+
+USES= bison cmake compiler:c++11-lib gettext kde:5 qt:5 tar:xz
+USE_KDE= ecm emoticons init itemmodels itemviews kdelibs4support
+USE_QT= core gui \
+ buildtools_build qmake_build
+USE_LDCONFIG= yes
+
+DESCR= ${.CURDIR:H:H}/deskutils/kdepim/pkg-descr
+
+OPTIONS_DEFINE= DOCS
+
+CONFLICTS_INSTALL= kcalcore-1*
+
+.include <bsd.port.mk>