aboutsummaryrefslogtreecommitdiffstats
path: root/net/kf5-kcontacts/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/kf5-kcontacts/Makefile')
-rw-r--r--net/kf5-kcontacts/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/net/kf5-kcontacts/Makefile b/net/kf5-kcontacts/Makefile
new file mode 100644
index 000000000000..1792c0a4ee4b
--- /dev/null
+++ b/net/kf5-kcontacts/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= kcontacts
+DISTVERSION= ${KDE_FRAMEWORKS_VERSION}
+PORTEPOCH= 1
+CATEGORIES= net kde kde-frameworks
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KDE api to manage contact information
+
+LICENSE= LGPL21
+
+BUILD_DEPENDS= iso-codes>=0:misc/iso-codes
+RUN_DEPENDS= iso-codes>=0:misc/iso-codes
+
+USES= cmake compiler:c++11-lib gettext kde:5 pkgconfig qt:5 tar:xz
+USE_KDE= ecm codecs config coreaddons i18n
+USE_QT= core dbus gui \
+ buildtools_build qmake_build
+USE_LDCONFIG= yes
+
+DESCR= ${.CURDIR:H:H}/deskutils/kdepim/pkg-descr
+
+OPTIONS_DEFINE= DOCS
+
+CONFLICTS_INSTALL= kcontacts-1*
+
+.include <bsd.port.mk>