aboutsummaryrefslogtreecommitdiffstats
path: root/net/mediastreamer
diff options
context:
space:
mode:
Diffstat (limited to 'net/mediastreamer')
-rw-r--r--net/mediastreamer/Makefile98
-rw-r--r--net/mediastreamer/distinfo6
-rw-r--r--net/mediastreamer/files/patch-00-9790349139
-rw-r--r--net/mediastreamer/files/patch-CMakeLists.txt11
-rw-r--r--net/mediastreamer/files/patch-cmake-FindGLX.cmake13
-rw-r--r--net/mediastreamer/files/patch-src-CMakeLists.txt22
-rw-r--r--net/mediastreamer/files/patch-src-base-msfactory.c20
-rw-r--r--net/mediastreamer/files/patch-src_videofilters_nowebcam.c24
-rw-r--r--net/mediastreamer/pkg-descr30
-rw-r--r--net/mediastreamer/pkg-plist34
10 files changed, 261 insertions, 136 deletions
diff --git a/net/mediastreamer/Makefile b/net/mediastreamer/Makefile
index 97611cb50db7..31825a638805 100644
--- a/net/mediastreamer/Makefile
+++ b/net/mediastreamer/Makefile
@@ -2,104 +2,92 @@
# $FreeBSD$
PORTNAME= mediastreamer
-PORTVERSION= 2.14.0
-PORTREVISION= 10
+PORTVERSION= 2.16.1
CATEGORIES= net
-MASTER_SITES= SAVANNAH/linphone/mediastreamer
+MASTER_SITES= https://www.linphone.org/releases/sources/mediastreamer/
-MAINTAINER= tijl@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Real-time audio and video streaming and processing
-LICENSE= GPLv2
+LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libbctoolbox.so:net/bctoolbox \
libortp.so:net/ortp \
- libsrtp.so:net/libsrtp \
+ libspeexdsp.so:audio/speexdsp \
+ libsrtp2.so:net/libsrtp2 \
libbzrtp.so:security/bzrtp
-CONFLICTS_INSTALL= linphone-base-[0-9]*
-
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-alsa --disable-documentation --disable-matroska \
- --disable-pulseaudio --disable-strict \
- --with-gsm=${LOCALBASE} --with-srtp=${LOCALBASE} \
- xxd_found=yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
-INSTALL_TARGET= install-strip
-USES= gettext-tools gmake libtool pathfix pkgconfig
-USE_GNOME= intlhack
+USES= cmake:outsource python:build
USE_LDCONFIG= yes
-OPTIONS_DEFINE= NLS UPNP VIDEO
+CMAKE_ARGS= -DENABLE_ALSA=NO -DENABLE_BV16=NO -DENABLE_DOC=NO \
+ -DENABLE_JPEG=NO -DENABLE_OSS=YES -DENABLE_PULSEAUDIO=NO \
+ -DENABLE_STATIC=NO -DENABLE_STRICT=NO -DENABLE_TOOLS=NO \
+ -DENABLE_UNIT_TESTS=NO
+
+OPTIONS_DEFINE= MATROSKA VIDEO
OPTIONS_GROUP= AUDIOOPT VIDEOOPT
-OPTIONS_GROUP_AUDIOOPT= GSM OPUS SPANDSP SPEEX
+OPTIONS_GROUP_AUDIOOPT= G726 G729 GSM OPUS SPEEX
OPTIONS_GROUP_VIDEOOPT= FFMPEG GLX THEORA V4L VPX XVIDEO
-OPTIONS_DEFAULT= UPNP VIDEO \
- GSM OPUS SPANDSP SPEEX \
+OPTIONS_DEFAULT= MATROSKA VIDEO \
+ G729 GSM OPUS SPEEX \
FFMPEG GLX THEORA V4L VPX XVIDEO
OPTIONS_SUB= yes
AUDIOOPT_DESC= Audio options
-FFMPEG_CONFIGURE_ENABLE=ffmpeg
+FFMPEG_IMPLIES= VIDEO
+FFMPEG_CMAKE_BOOL= ENABLE_FFMPEG
FFMPEG_LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg
-GLX_CONFIGURE_ENABLE= glx
+G726_CMAKE_BOOL= ENABLE_G726
+G726_DESC= G.726 codec support
+G726_LIB_DEPENDS= libspandsp.so:comms/spandsp
+
+G729_CMAKE_BOOL= ENABLE_G729
+G729_DESC= G.729 codec support
+G729_LIB_DEPENDS= libbcg729.so:audio/bcg729
+
+GLX_IMPLIES= VIDEO
+GLX_CMAKE_BOOL= ENABLE_GL ENABLE_GLX
GLX_USE= GL=glew
-GSM_CONFIGURE_ENABLE= gsm
+GSM_CMAKE_BOOL= ENABLE_GSM
GSM_LIB_DEPENDS= libgsm.so:audio/gsm
-NLS_CONFIGURE_ENABLE= nls
-NLS_USES= gettext-runtime
+MATROSKA_CMAKE_BOOL= ENABLE_MKV
+MATROSKA_LIB_DEPENDS= libbcmatroska2.so:multimedia/bcmatroska2
-OPUS_CONFIGURE_ENABLE= opus
+OPUS_CMAKE_BOOL= ENABLE_OPUS
OPUS_LIB_DEPENDS= libopus.so:audio/opus
-SPANDSP_CONFIGURE_ENABLE= spandsp
-SPANDSP_LIB_DEPENDS= libspandsp.so:comms/spandsp
-
-SPEEX_CONFIGURE_ENABLE= speex
+SPEEX_CMAKE_BOOL= ENABLE_SPEEX_CODEC
SPEEX_LIB_DEPENDS= libspeex.so:audio/speex
-THEORA_CONFIGURE_ENABLE=theora
+THEORA_IMPLIES= VIDEO
+THEORA_CMAKE_BOOL= ENABLE_THEORA
THEORA_LIB_DEPENDS= libtheora.so:multimedia/libtheora
-UPNP_CONFIGURE_ENABLE= upnp
-UPNP_LIB_DEPENDS= libupnp.so:devel/upnp
-
-V4L_CONFIGURE_ENABLE= v4l
+V4L_IMPLIES= VIDEO
+V4L_CMAKE_BOOL= ENABLE_V4L
V4L_BUILD_DEPENDS= v4l_compat>=1.0.20120501:multimedia/v4l_compat
V4L_LIB_DEPENDS= libv4l2.so:multimedia/libv4l
VIDEOOPT_DESC= Video options
-VIDEO_CONFIGURE_ENABLE= video
+VIDEO_CMAKE_BOOL= ENABLE_VIDEO
-VPX_CONFIGURE_ENABLE= vp8
+VPX_IMPLIES= VIDEO
+VPX_CMAKE_BOOL= ENABLE_VPX
VPX_LIB_DEPENDS= libvpx.so:multimedia/libvpx
-XVIDEO_CONFIGURE_ENABLE=x11 xv
+XVIDEO_IMPLIES= VIDEO
+XVIDEO_CMAKE_BOOL= ENABLE_X11 ENABLE_XV
XVIDEO_USE= XORG=xorgproto,x11,xv
-.if defined(WITH_DEBUG)
-CONFIGURE_ARGS+=--enable-debug
-.endif
-
post-patch:
@${REINPLACE_CMD} 's,gsm/gsm\.h,gsm.h,' \
- ${WRKSRC}/configure ${WRKSRC}/src/audiofilters/gsm.c
-
-pre-build:
-# Transform file to C array (similar to xxd -i from editors/vim)
-.for i in yuv2rgb.fs yuv2rgb.vs
- (cd ${WRKSRC}/src && { \
- ${ECHO_CMD} 'unsigned char ${i:S/./_/}[] = {' && \
- /usr/bin/hexdump -v -e '" " 12/1 " 0x%02x," "\n" \
- " 0x00 };\nunsigned int ${i:S/./_/}_len = %_Ad;"' ${i} | \
- ${SED} 's/ 0x ,//g' ; } > ${i}.h)
-.endfor
+ ${WRKSRC}/cmake/FindGSM.cmake ${WRKSRC}/src/audiofilters/gsm.c
.include <bsd.port.mk>
diff --git a/net/mediastreamer/distinfo b/net/mediastreamer/distinfo
index 7276b3fe969a..29e4baacfb5e 100644
--- a/net/mediastreamer/distinfo
+++ b/net/mediastreamer/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1476373165
-SHA256 (mediastreamer-2.14.0.tar.gz) = 1144849c0c96abafb1153adf56109f0f195a9e4a53cf28cb611bbca7a9012c1a
-SIZE (mediastreamer-2.14.0.tar.gz) = 6388303
+TIMESTAMP = 1506006953
+SHA256 (mediastreamer-2.16.1.tar.gz) = 33351f9409e229a00aaf831930916e1934d8e972773e95f7b7177c9e4cc61772
+SIZE (mediastreamer-2.16.1.tar.gz) = 18904458
diff --git a/net/mediastreamer/files/patch-00-9790349 b/net/mediastreamer/files/patch-00-9790349
new file mode 100644
index 000000000000..8e3d04a0adf0
--- /dev/null
+++ b/net/mediastreamer/files/patch-00-9790349
@@ -0,0 +1,139 @@
+diff --git a/cmake/FindSRTP.cmake b/cmake/FindSRTP.cmake
+index 988b846a..f720ce7e 100644
+--- cmake/FindSRTP.cmake
++++ cmake/FindSRTP.cmake
+@@ -31,20 +31,36 @@ set(_SRTP_ROOT_PATHS
+ )
+
+ find_path(SRTP_INCLUDE_DIRS
+- NAMES srtp/srtp.h
++ NAMES srtp2/srtp.h
+ HINTS _SRTP_ROOT_PATHS
+ PATH_SUFFIXES include
+ )
+
+ if(SRTP_INCLUDE_DIRS)
+ set(HAVE_SRTP_SRTP_H 1)
+-endif()
+-
+-find_library(SRTP_LIBRARIES
++ set(SRTP_VERSION 2)
++ find_library(SRTP_LIBRARIES
++ NAMES srtp2
++ HINTS ${_SRTP_ROOT_PATHS}
++ PATH_SUFFIXES bin lib
++ )
++else()
++ find_path(SRTP_INCLUDE_DIRS
++ NAMES srtp/srtp.h
++ HINTS _SRTP_ROOT_PATHS
++ PATH_SUFFIXES include
++ )
++ if(SRTP_INCLUDE_DIRS)
++ set(HAVE_SRTP_SRTP_H 1)
++ set(SRTP_VERSION 1)
++ endif()
++ find_library(SRTP_LIBRARIES
+ NAMES srtp
+ HINTS ${_SRTP_ROOT_PATHS}
+ PATH_SUFFIXES bin lib
+ )
++endif()
++
+
+ include(FindPackageHandleStandardArgs)
+ find_package_handle_standard_args(SRTP
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index da429764..c46faa62 100644
+--- src/CMakeLists.txt
++++ src/CMakeLists.txt
+@@ -183,6 +183,7 @@ set(VOIP_SOURCE_FILES_C
+ utils/pcap_sender.c
+ utils/pcap_sender.h
+ utils/stream_regulator.c
++ utils/srtp_prefix.h
+ voip/audioconference.c
+ voip/audiostream.c
+ voip/bandwidthcontroller.c
+diff --git a/src/crypto/ms_srtp.c b/src/crypto/ms_srtp.c
+index 5a510c99..67810316 100644
+--- src/crypto/ms_srtp.c
++++ src/crypto/ms_srtp.c
+@@ -25,6 +25,7 @@
+ #include "mediastreamer2/ms_srtp.h"
+ #include "mediastreamer2/mediastream.h"
+
++
+ #ifdef HAVE_SRTP
+
+ /*srtp defines all this stuff*/
+@@ -34,13 +35,7 @@
+ #undef PACKAGE_TARNAME
+ #undef PACKAGE_VERSION
+
+-#if defined(MS2_WINDOWS_PHONE)
+-// Windows phone doesn't use make install
+-#include <srtp.h>
+-#else
+-#include <srtp/srtp.h>
+-#endif
+-
++#include "srtp_prefix.h"
+
+ #include "ortp/b64.h"
+
+@@ -352,7 +347,6 @@ int ms_srtp_init(void)
+ srtp_init_done++;
+ }else{
+ ms_fatal("Couldn't initialize SRTP library: %d.", st);
+- err_reporting_init("mediastreamer2");
+ }
+ }else srtp_init_done++;
+ return (int)st;
+diff --git a/src/utils/srtp_prefix.h b/src/utils/srtp_prefix.h
+new file mode 100644
+index 00000000..68bde496
+--- /dev/null
++++ src/utils/srtp_prefix.h
+@@ -0,0 +1,41 @@
++/*
++ mediastreamer2 library - modular sound and video processing and streaming
++ Copyright (C) 2006-2014 Belledonne Communications, Grenoble
++
++ This library is free software; you can redistribute it and/or
++ modify it under the terms of the GNU Lesser General Public
++ License as published by the Free Software Foundation; either
++ version 2.1 of the License, or (at your option) any later version.
++
++ This library is distributed in the hope that it will be useful,
++ but WITHOUT ANY WARRANTY; without even the implied warranty of
++ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
++ Lesser General Public License for more details.
++
++ You should have received a copy of the GNU Lesser General Public
++ License along with this library; if not, write to the Free Software
++ Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
++*/
++#ifndef __SRTP2_H__
++#define __SRTP2_H__
++
++#if defined(MS2_WINDOWS_PHONE)
++// Windows phone doesn't use make install
++#include <srtp.h>
++#elif SRTP_VERSION==1
++#include <srtp/srtp.h>
++#else
++#include <srtp2/srtp.h>
++#define err_status_t srtp_err_status_t
++#define err_status_ok srtp_err_status_ok
++#define crypto_policy_t srtp_crypto_policy_t
++#define crypto_policy_set_aes_cm_256_hmac_sha1_80 srtp_crypto_policy_set_aes_cm_256_hmac_sha1_80
++#define crypto_policy_set_aes_cm_128_hmac_sha1_32 srtp_crypto_policy_set_aes_cm_128_hmac_sha1_32
++#define crypto_policy_set_aes_cm_128_null_auth srtp_crypto_policy_set_aes_cm_128_null_auth
++#define crypto_policy_set_null_cipher_hmac_sha1_80 srtp_crypto_policy_set_null_cipher_hmac_sha1_80
++#define crypto_policy_set_aes_cm_128_hmac_sha1_80 srtp_crypto_policy_set_aes_cm_128_hmac_sha1_80
++#define crypto_policy_set_aes_cm_256_hmac_sha1_32 srtp_crypto_policy_set_aes_cm_256_hmac_sha1_32
++#define ssrc_t srtp_ssrc_t
++#endif
++
++#endif
diff --git a/net/mediastreamer/files/patch-CMakeLists.txt b/net/mediastreamer/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..2a6da2e6d930
--- /dev/null
+++ b/net/mediastreamer/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2017-07-21 13:00:14 UTC
++++ CMakeLists.txt
+@@ -139,7 +139,7 @@ if(ENABLE_OSS)
+ endif()
+ endif()
+
+-check_library_exists("dl" "dlopen" "" HAVE_DLOPEN)
++set(HAVE_DLOPEN 1)
+
+ include(TestBigEndian)
+ test_big_endian(WORDS_BIGENDIAN)
diff --git a/net/mediastreamer/files/patch-cmake-FindGLX.cmake b/net/mediastreamer/files/patch-cmake-FindGLX.cmake
new file mode 100644
index 000000000000..48c566f767bc
--- /dev/null
+++ b/net/mediastreamer/files/patch-cmake-FindGLX.cmake
@@ -0,0 +1,13 @@
+--- cmake/FindGLX.cmake.orig 2017-04-06 09:27:56 UTC
++++ cmake/FindGLX.cmake
+@@ -39,8 +39,8 @@ find_path(GLX_INCLUDE_DIRS
+ PATH_SUFFIXES include
+ )
+ if(GLX_INCLUDE_DIRS)
+- check_include_file(GL/gl.h HAVE_GL_GL_H)
+- check_include_file(GL/glx.h HAVE_GL_GLX_H)
++ check_include_file(GL/gl.h HAVE_GL_GL_H "-I${GLX_INCLUDE_DIRS}")
++ check_include_file(GL/glx.h HAVE_GL_GLX_H "-I${GLX_INCLUDE_DIRS}")
+ endif()
+
+ find_library(GL_LIBRARY
diff --git a/net/mediastreamer/files/patch-src-CMakeLists.txt b/net/mediastreamer/files/patch-src-CMakeLists.txt
new file mode 100644
index 000000000000..5c1ed0de810a
--- /dev/null
+++ b/net/mediastreamer/files/patch-src-CMakeLists.txt
@@ -0,0 +1,22 @@
+--- src/CMakeLists.txt.orig 2017-07-21 12:59:53 UTC
++++ src/CMakeLists.txt
+@@ -79,9 +79,6 @@ set(BASE_LIBS
+ if(WIN32 AND NOT CMAKE_SYSTEM_NAME STREQUAL "WindowsPhone" AND NOT CMAKE_SYSTEM_NAME STREQUAL "WindowsStore")
+ list(APPEND BASE_LIBS ${LIBGCC} ${LIBMINGWEX} ole32 oleaut32 uuid Winmm Ws2_32)
+ endif()
+-if(HAVE_DLOPEN)
+- list(APPEND BASE_LIBS dl)
+-endif()
+
+ bc_apply_compile_flags(BASE_SOURCE_FILES_C STRICT_OPTIONS_CPP STRICT_OPTIONS_C)
+
+@@ -550,9 +547,6 @@ if(ANDROID_SUPPORT_LIBRARY)
+ endif()
+ if(ANDROID AND ENABLE_VIDEO)
+ list(APPEND VOIP_LIBS GLESv2)
+-endif()
+-if(HAVE_DLOPEN)
+- list(APPEND VOIP_LIBS dl)
+ endif()
+ if(PCAP_FOUND)
+ list(APPEND VOIP_LIBS ${PCAP_LIBRARIES})
diff --git a/net/mediastreamer/files/patch-src-base-msfactory.c b/net/mediastreamer/files/patch-src-base-msfactory.c
index f69a79abb241..86c1b29e512c 100644
--- a/net/mediastreamer/files/patch-src-base-msfactory.c
+++ b/net/mediastreamer/files/patch-src-base-msfactory.c
@@ -1,6 +1,22 @@
---- src/base/msfactory.c.orig 2015-03-02 11:36:25 UTC
+--- src/base/msfactory.c.orig 2017-07-20 13:56:05 UTC
+++ src/base/msfactory.c
-@@ -157,7 +157,7 @@ void ms_factory_init(MSFactory *obj){
+@@ -20,14 +20,13 @@ Foundation, Inc., 51 Franklin Street, Fifth Floor, Bos
+ #ifdef HAVE_CONFIG_H
+ #include "mediastreamer-config.h"
+ #include "gitversion.h"
+-#else
++#endif
+ # ifndef MEDIASTREAMER_VERSION
+ # define MEDIASTREAMER_VERSION "unknown"
+ # endif
+ # ifndef MS2_GIT_VERSION
+ # define MS2_GIT_VERSION "unknown"
+ # endif
+-#endif
+
+ #include "mediastreamer2/msfilter.h"
+ #include "mediastreamer2/mseventqueue.h"
+@@ -184,7 +183,7 @@ void ms_factory_init(MSFactory *obj){
GetNativeSystemInfo( &sysinfo );
num_cpu = sysinfo.dwNumberOfProcessors;
diff --git a/net/mediastreamer/files/patch-src_videofilters_nowebcam.c b/net/mediastreamer/files/patch-src_videofilters_nowebcam.c
deleted file mode 100644
index 2715035cba5b..000000000000
--- a/net/mediastreamer/files/patch-src_videofilters_nowebcam.c
+++ /dev/null
@@ -1,24 +0,0 @@
-videofilters/nowebcam.c:251:49: error: use of undeclared identifier 'FF_INPUT_BUFFER_PADDING_SIZE'
- jpgbuf=(uint8_t*)ms_malloc0(statbuf.st_size + FF_INPUT_BUFFER_PADDING_SIZE);
- ^
-
---- src/videofilters/nowebcam.c.orig 2016-08-18 14:17:37 UTC
-+++ src/videofilters/nowebcam.c
-@@ -32,7 +32,7 @@ Foundation, Inc., 59 Temple Place - Suite 330, Boston,
- #ifndef NO_FFMPEG
- #include "ffmpeg-priv.h"
- #else
--#define FF_INPUT_BUFFER_PADDING_SIZE 32
-+#define AV_INPUT_BUFFER_PADDING_SIZE 32
- #endif
-
- #if TARGET_OS_IPHONE
-@@ -248,7 +248,7 @@ static mblk_t *_ms_load_jpeg_as_yuv(const char *jpgpat
- ms_error("Cannot load %s",jpgpath);
- return NULL;
- }
-- jpgbuf=(uint8_t*)ms_malloc0(statbuf.st_size + FF_INPUT_BUFFER_PADDING_SIZE);
-+ jpgbuf=(uint8_t*)ms_malloc0(statbuf.st_size + AV_INPUT_BUFFER_PADDING_SIZE);
- if (jpgbuf==NULL)
- {
- close(fd);
diff --git a/net/mediastreamer/pkg-descr b/net/mediastreamer/pkg-descr
index 5062b5e49096..662c3bb658d7 100644
--- a/net/mediastreamer/pkg-descr
+++ b/net/mediastreamer/pkg-descr
@@ -1,34 +1,4 @@
Mediastreamer2 is a powerful and lightweight streaming engine specialized
in voice/video telephony applications.
-It is the library that is responsible for all the receiving and sending of
-multimedia streams in linphone, including voice/video capture, encoding and
-decoding, and rendering.
-
-Features:
-
-* Capture and playback from various platform dependent sound architectures
-* Send and receive RTP streams
-* Encode and decode the following audio formats: OPUS, speex, G711, GSM, iLBC,
- AMR, AMR-WB, G722, SILK, G729, and video formats H263, theora, MPEG4,
- H264 and VP8
-* RTP/AVPF support: RTCP control messages for video error recovery: PLI, SLI,
- RPSI, FIR
-* Audio conferencing
-* Supports SRTP and ZRTP (encryption of voice and video)
-* Supports any webcam, based on OS's camera API: quicktime, directshow,
- video4linux, android.camera
-* Acoustic echo cancellation using the speex echo canceler or webrtc AECm
-* Read and write .wav files
-* Optimized rendering of YUV pictures, using OpenGL, DrawDib, X11/Xv
-* Dual tones generation
-* Custom tone detector
-* Audio parametric equalizer
-* Volume control, automatic gain control
-* ICE for optimized NAT traversal (RFC5246) to allow peer to peer audio and
- video connections without media relay server
-* Adaptive bitrate control algorithm: for automatic adaption of encoder
- bitrate based on received RTCP feedback
-* Can use plugins to add new codecs, new sound input/output backends,...
-
WWW: https://www.linphone.org/technical-corner/mediastreamer2.html
diff --git a/net/mediastreamer/pkg-plist b/net/mediastreamer/pkg-plist
index 2fb87db2c5ed..7c59465c66d4 100644
--- a/net/mediastreamer/pkg-plist
+++ b/net/mediastreamer/pkg-plist
@@ -1,5 +1,3 @@
-bin/mediastream
-bin/msaudiocmp
include/mediastreamer2/allfilters.h
include/mediastreamer2/bitratecontrol.h
include/mediastreamer2/bits_rw.h
@@ -12,6 +10,7 @@ include/mediastreamer2/formats.h
include/mediastreamer2/ice.h
include/mediastreamer2/mediastream.h
include/mediastreamer2/ms_srtp.h
+include/mediastreamer2/msasync.h
include/mediastreamer2/msaudiomixer.h
include/mediastreamer2/mschanadapter.h
include/mediastreamer2/mscodecutils.h
@@ -30,6 +29,9 @@ include/mediastreamer2/msitc.h
include/mediastreamer2/msjava.h
include/mediastreamer2/msjpegwriter.h
include/mediastreamer2/msmediaplayer.h
+include/mediastreamer2/msogl.h
+include/mediastreamer2/msogl_functions.h
+include/mediastreamer2/mspcapfileplayer.h
include/mediastreamer2/msqueue.h
include/mediastreamer2/msrtp.h
include/mediastreamer2/msrtt4103.h
@@ -37,6 +39,7 @@ include/mediastreamer2/mssndcard.h
include/mediastreamer2/mstee.h
include/mediastreamer2/msticker.h
include/mediastreamer2/mstonedetector.h
+include/mediastreamer2/msudp.h
include/mediastreamer2/msutils.h
include/mediastreamer2/msv4l.h
include/mediastreamer2/msvaddtx.h
@@ -52,24 +55,11 @@ include/mediastreamer2/upnp_igd.h
include/mediastreamer2/x11_helper.h
include/mediastreamer2/zrtp.h
lib/libmediastreamer_base.so
-lib/libmediastreamer_base.so.7
-lib/libmediastreamer_base.so.7.0.0
+lib/libmediastreamer_base.so.10
lib/libmediastreamer_voip.so
-lib/libmediastreamer_voip.so.7
-lib/libmediastreamer_voip.so.7.0.0
-libdata/pkgconfig/mediastreamer.pc
-share/images/nowebcamCIF.jpg
-%%NLS%%share/locale/cs/LC_MESSAGES/mediastreamer.mo
-%%NLS%%share/locale/de/LC_MESSAGES/mediastreamer.mo
-%%NLS%%share/locale/es/LC_MESSAGES/mediastreamer.mo
-%%NLS%%share/locale/fr/LC_MESSAGES/mediastreamer.mo
-%%NLS%%share/locale/hu/LC_MESSAGES/mediastreamer.mo
-%%NLS%%share/locale/it/LC_MESSAGES/mediastreamer.mo
-%%NLS%%share/locale/ja/LC_MESSAGES/mediastreamer.mo
-%%NLS%%share/locale/nl/LC_MESSAGES/mediastreamer.mo
-%%NLS%%share/locale/pl/LC_MESSAGES/mediastreamer.mo
-%%NLS%%share/locale/pt_BR/LC_MESSAGES/mediastreamer.mo
-%%NLS%%share/locale/ru/LC_MESSAGES/mediastreamer.mo
-%%NLS%%share/locale/sv/LC_MESSAGES/mediastreamer.mo
-%%NLS%%share/locale/zh_CN/LC_MESSAGES/mediastreamer.mo
-@dir lib/mediastreamer/plugins
+lib/libmediastreamer_voip.so.10
+share/Mediastreamer2/cmake/Mediastreamer2Config.cmake
+share/Mediastreamer2/cmake/Mediastreamer2ConfigVersion.cmake
+share/Mediastreamer2/cmake/Mediastreamer2Targets-%%CMAKE_BUILD_TYPE%%.cmake
+share/Mediastreamer2/cmake/Mediastreamer2Targets.cmake
+%%VIDEO%%share/images/nowebcamCIF.jpg