aboutsummaryrefslogtreecommitdiffstats
path: root/net/mldonkey/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/mldonkey/Makefile')
-rw-r--r--net/mldonkey/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/net/mldonkey/Makefile b/net/mldonkey/Makefile
index 24a3d5fffebc..d74459c19109 100644
--- a/net/mldonkey/Makefile
+++ b/net/mldonkey/Makefile
@@ -48,6 +48,12 @@ PLIST_SUB+= CORE="" GUICORE=""
DOCFILES= Authors.txt Bugs.txt ChangeLog Developers.txt FAQ.html \
Install.txt Readme.txt Todo.txt ed2k_links.txt
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
pre-everything::
.if !defined(WITHOUT_GUI) && !defined(WITHOUT_CORE)
@${ECHO_MSG} "You can disable the GUI by defining WITHOUT_GUI."
@@ -93,4 +99,4 @@ install-user: extract
${HOME}/.mldonkey_gui_messages.ini
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>